Remote command failed with exit status 1


#21

Like legts said, this doesn’t show a problem, just that no robot code was running. To find out why the robot code isn’t running, please post your riolog, which will hopefully have a stack trace.


#22

I’m going to sound like a naive rookie, (which I kinda am) but how exactly do you do that?


#23

http://wpilib.screenstepslive.com/s/4485/m/13809/l/284333-using-riolog-to-view-console-output


#24

Thanks Joe. We solved the problem on our own, it was actually a HARDWARE issue. If anyone else is having this problem, we may be able to help because the “Remote command failed with exit status 1” message is not what’s making the code not push. If the build is successful, the problem is the roboRIO.


#25

–ONE SOLUTION–
If you are using JAVA make sure that you have installed the JRE as descrbed

https://wpilib.screenstepslive.com/s/4485/m/13503/l/288822-installing-java-8-on-the-roborio-using-the-frc-roborio-java-installer-java-only


#26

We have also had this problem on one of our test bench robots. After our RoboRio failed to run java code, we re-imaged it. Using the same java file that was being successfully sent to the robot earlier, we kept getting the same error with 2 different computers, both of which had eclipse mars and luna installed. How did you guys get the hardware fixed?


#27

Sounds like you need to install the KRE as described in the post right above yours.

The FRC deployment scripts run something like a dozen remote commands on the roboRIO, this error by itself is fairly useless. If you are sure the JRE is loaded, post the whole deploy log.


#28

OK. We realized we had never installed the roboRio hardware updates, and once we updated that it works just fine.

Unfortunately, our code still won’t control the motors, but that is a different problem.