Reset radio after competition

Hello everyone, I’m from a new team in Brazil, and as we are still starting, we have a doubt about the radio. we don’t know how to reset it after the competition, so it’s quite annoying to deploy new codes over cable. what procedure is required? we have already tried going to frc radio configuration, but it shows errors when we click on “configure”, even recognizing the firmware. we have already disabled the other network adapters other than ethernet. what we need to do?

Verify that all the network adapters are disabled other than the ethernet. Let the radio sit for a while powered on (a few min). I have always had issues if I have if powered using POE and have had much more success when I use the barrel jack (This doesn’t make since to me just based on personal observation).

If these tips do not work, try a different computer. I have found that we have some computers that just do not seem to work no matter what we try, but others work fine when all the network adapters other than ethernet are disabled.

If those tips don’t help, what specific errors are you getting from the radio configuration tool?

Also try a few different computers. There are some computers where the software just doesn’t work for whatever reason. Try to find computers with Microsoft account names in English (with no non-English characters) as that has also been known to cause issues.

We have 2 laptops from the same model, one of them will config radios just fine, the other won’t. They’re both set up in English. Maybe it’s some software downloaded to one of them but not the other.
My point is it could be so many things, you might as well treat it as a lottery when it comes to the ability to config a radio.

the error occurs only in the configuration. When I press on firmware, it recognizes and completes successfully. The problem is in configure, which fails only in the final part: “reconnecting to bridge at team ip address”.



1 Like

I already tested it with two other PCs, the error remains the same

we tested it, but the error remains only in the “configure” part

unfortunately we only have the POE to carry out the voltage supply

Have you tried everything in the troubleshooting section on WPILib (Programming your Radio — FIRST Robotics Competition documentation), specifically setting the computer’s system locale to en_us or trying to install npcap?

I saw some radios that somehow were configured successfully despite having the “validation error”. Did you try using the radio after the config tool presumably failed to validate the configuration?

yes, I had already checked these two steps too, since before installing npcap, even the firmware didn’t work, so I was hopeful before the “configure” ip error came along. However, something strange happened, after pressing the reset button of the radio once again, unlike before he applied the changes and created a stable connection with the radio, even with the error message appearing. Any idea what that mistake might have been? since before he didn’t even create a connection before.

Yes, I tested it, and it still didn’t work. Even the name of the radio remained the same as it was defined in the on season. However, something strange happened, after I pressed the Reset button one more time, even with the error message appearing, exactly what you said happened! the settings were applied, even with the error message appearing, and a stable connection was created. My big question for all this, is why this time the changes were applied with the error message appearing, even though I didn’t change anything in relation to the other attempts? radio factory problem?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.