REV Color Sensor Error Message & No LED power

Any help on this error message
"i2clib_writeread.vi

Input/output error

Complete call chain:
i2clib_writeread.vi
WPI_I2CRead.vi
Color Sensor V3 Read8.vi
Color Sensor V3 Check Device ID.vi
Color Sensor V3 Open.vi
Robot Main.vi "

I have the LabVIEW Libraries installed and ran the sample code but can’t turn the LED on manually. Is the LED supposed to work just when plugged in/robot enabled?

Is there a way to control the LED though code? I only saw the physical switch you have in the sensor.

The LED on the Color Sensor V3 should always be on if the switch is in the correct position and the roboRIO is on. Make sure you have plugged the device in to the I2C port in the correct orientation.

1 Like

Thanks I thought that might be true. The port was correctly oriented with ground(black) to the outside of the RoboRIO and I ran voltage checks on the rail and the end of the wire to confirm power was making through to the sensor.

My Color Sensor is still not working. Is there any first steps I am missing or does it just get plugged. Anyone else have an issue with getting the LED to turn on?

It really should be as easy as plug it in and the LED turns on (with the switch in the right position). If this is not the case send us an email at support@revrobotics.com

1 Like


I think the wire that was sent with the kit of parts has the JST pin housing upside down. With the wire end pointing up and the ‘key’ away from me it is Blue White Red Black. Looking at the Data Sheet on Rev it looks like the pin out is the opposite. Can anyone confirm?

Yep. That is backwards. Please send us an email at support@revrobotics.com and we’ll get you a new cable.

2 Likes