REV Hardware Client Not Burning Config Firmware

Hello all,
Having some odd issue where the REV Hardware Client is not burning config firmware to the attached SPARK MAX motor controllers.

Steps to replicate:

  1. Run REV Hardware Client
  2. Connect SPARK MAX to computer via USB-C
  3. Wait for REVHC to see the device (usually also takes several re-plugs of the USB cable, or several ‘Scan for Devices’)
  4. SPARK MAX is discovered
  5. Change SPARK MAX ‘CAN ID’ property to be non-zero (i.e. 2)
  6. Click ‘Burn Flash’
  7. Wait for success message (approx 30s-1m)
  8. Top right displays CAN ID as (correct) set value
  9. Re-plug motor controller, or ‘Scan for Devices’ again

Expected Result:
The discovered motor controller’s CAN ID should be set to the previously set, non-zero, value.

Actual Result:
The discovered motor controller’s CAN ID is set to zero.

Attempted Fixes:

  • Trying another SPARK MAX
  • Trying different CAN ID values, as well as different config options
  • Downgrading firmware versions to 1.5.0 and 1.5.1 (firmware successfully downgraded, but still can’t change config)
  • Reinstalling software
  • Reinstalling firmware
  • Reinstall drivers
  • Run REV Hardware Client as Administrator
  • Complete factory reset of motor controller
  • Put motor controller under recovery mode, re-flash firmware

Computer Specs:
Computer Type: ThinkPad X1 Yoga 4th
Windows Version: Microsoft Windows 10 Education
Version: 10.0.19042 Build 19042
System Type: x64-based PC
SKU: LENOVO_MT_20UC_BU_Think_FM_ThinkPad X1 Yoga Gen 4
Processor: Intel(R) Core™ i5-10210U CPU @ 1.60GHz, 2112 Mhz, 4 Core(s), 8 Logical Processor(s)
BIOS Version: LENOVO N2WET27W (1.17), 3/29/2021
RAM: 16.0 GB

Software Specs:
REV Hardware client: 1.4.0
SPARK MAX Version: 1.5.2

Anyone encounter a similar problem and find a fix?

Hey! Worked through this issue myself and found that using version 1.3.0 of the REV Hardware Client (found here) solved the issue for me.

Hope this helps!

1 Like

Yes! Thank you so much!
That fixed the issue, and we’re now able to flash the SPARKs properly. :smile:

Additional Note:

As it turned out, some of the SPARKs were also on an older version firmware version (1.4.0).

The 1.3.0 version of REV was unable to update the firmware of the SPARKs to the latest version (1.5.2) for some reason – kept crashing. So we actually had to use the 1.4.0 version of REV to update the firmware from 1.4.0 to 1.5.2, and then we had to use the 1.3.0 version of REV to update the config options for the SPARKs.

Used REV 1.4.0 to update SPARK firmware version.
Used REV 1.3.0 to update SPARK config.

We’re looking into this. The software version shuffle shouldn’t be necessary. :slightly_smiling_face:

We just released REV Hardware Client version 1.4.1, which fixes this issue. You can update from the About tab.


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.