REV PDH Error

My team has been experiencing issues with the new REV Power Distribution Hubs. It all started when I tried to access the CAN Network using the USB-C connection in the REV Hardware Client. I could see all the devices in the CAN network, but the Client told me the REV devices needed updates. When I tried to update them, the update failed, so I looked at the signal lights for the PDH. It looked like they were blinking orange and magenta which would suggest a Device Over Current error (according to REV documentation). We had a second REV PDH that we plugged into the battery with no other cables attached to it but the one to the battery. The second PDH then blinked orange and blue which would suggest Low Battery. We unattached all the wires from the first PDH and did the same test on it, and it still blinked orange and magenta using the same battery. Unfortunately, this was done this Saturday, so REV support does not have office hours today (I called to see). Any ideas on what could be the problem would be helpful.
Thank you.

1 Like

Let’s start with a good photo of your setup.

Unfortunately, the set-up has been taken apart (multiple times) and put back on a CTRE PDP for now. The electrical team did follow the picture of the REV Control System on the documentation.

Edit: I do have a picture of one of the PDH’s with some breakers and fuses in it after we took it apart.


In this image, it’s not connected to the battery in the picture, but this is the one that gave us the Device Over Current error when it was connected (with the same set up otherwise).

1 Like

First let’s try to get the devices updated to the latest firmware. Factory firmware may have different LED codes than 2022 competition firmware.

Make sure your client is up to date (version 1.4.1 as of this date). Then, to limit the number of variables, try only connecting to one standalone device and update the firmware.

Thank you for the advice. I will try doing this when I am at our build space again.
My client (version 1.4.1) was downloaded today. However, I just realized that I should have been more specific to the error I was getting that wouldn’t let me update the software in the first place. REV Hardware Client said that it failed to write on the PDH’s disk. Before I tried to update the PDH, the Hardware Client knew that the software was out of date. Afterward, the Client said that the version was unknown. Could I have erased the factory default firmware without replacing it because of a failed write?

So I had tried to do update them one at a time in a set up similar to the one above, and it did fail on the day I originally posted. I just got back in the shop and booted everything up, and it worked as described in the documentation.

Lessons Learned: You may need to force the REV Hardware Manager to run as Administrator. I’m not sure exactly if this was the problem or not, but it seems to be the most logical option since our electrical layout was the same. I would suggest that making sure you are in administrator be explicitly mentioned in the documentation because I think the app might not have been running as administrator as I opened it from the installer.

Once again, thank you all for your help and have a great rest of the season.

Glad to hear you got it working!

This was going to be my next suggestion, since you got a “failed to write to disk” error, it could be a permissions issues writing to the computer’s hard disk, or a disk space issue like @NoahAndrews mentions below.

1 Like

How much disk space did you have remaining? Administrator-level permissions shouldn’t be required.

I’m not sure exactly. All I know for sure booted the computer up the next day I was at the shop, and it worked as shown in the documentation.

I didn’t think about Administrator-level permissions until later because it didn’t really make sense to require Administrator as the disk on the device was being changed and not the computer itself. I’m not sure if there was anything else I did differently from finding the error on the first day and the Hardware Manager working on the other day.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.