Rev Radio Power Module - No Data Connection to Radio

We have the rev radio power module all set and it is providing power to the radio. But after about 10-20 seconds the Ethernet status lights go off and there is not data connection flowing through to the radio. We tried a second power module and we are getting the same result. Any ideas?

Can you provide some pictures of your wiring? Specifically ethernet connections

Here are some pictures of the connections and a video of it starting up.


Thanks for sending photos. Do you have any photos of the wiring leading into the RPM?

The data lines are directly wired from the input connector to the output connector. If the RPM was the source of the issue, it would likely be power related and not data related. From your description, it sounds like the radio has consistent power, so this may indicate there is an issue somewhere else in the path, like the radio itself, ethernet cables, or the roboRIO.

Please reach out to us at [email protected]. We’ll need some more details on what troubleshooting steps you’ve taken already. For example, have you tried powering the radio with some of the other legal configurations?

Hopefully we can get you up and running quickly!

1 Like

We began encountering what sounds like a similar issue last night. @joseppi could you confirm or deny whether what we observed is the same issue you are facing?

  1. Connecting wirelessly will work at first, but the comms light on the Driver Station will go out after 5-30 seconds, and then return after 10-15 more seconds.
  2. Deploying code wirelessly is a surefire way to kill the comms light.
    a. The build will succeed, but the deploy will fail halfway through.
  3. We are connected to the radio’s wireless signal the entire time and the radio maintains power.
  4. We have connected our laptop straight to the RPM (which then goes straight to the Rio), which is much more stable, but will occasionally drop signal about 1 in 10 deploys. The deploy from here, however, takes about 3x as long as a USB deploy (about 30-40 seconds for a non-fresh build).
  5. A USB connection to the Rio will work perfectly (deploys take about 10-15 seconds).

We have not tried:

  1. Extended testing while connected over ethernet directly to the Rio
  2. Deploying a brand new robot project
  3. Re-imaging the radio
  4. Re-imaging the Rio

We will be trying those 4 tonight. We are on the latest wpilib version, the latest rio1 image/firmware, and the latest radio firmware. Maybe just redoing something will fix it. I don’t know.

1 Like

Our issue was a little different. The radio appeared to boot but did not stay powered long enough to connect the driver station or any other computer.

We do appear to have resolved the issue. There are two things we did, not sure if both were necessary or not.

  1. This was a new Rio 2 and we had formatted it and set our team number but we had not put robot code on it yet. So today we installed the RobotPy libraries and deployed our code to the robot.

  2. We were using a 2020 radio and could not get the firmware to update. We switched to an unused 2021 radio, updated the firmware and configured and now all is well.

Now the RPM is handling the power and data without issue.

I would love to know if the mesh radio firmware and robot code are necessary for the RPM to pass data?


The data lines are just a strict pass-through. Its power regulation is not dependent on the presence or absence of ethernet signals.

It looks like in your new video, you are no longer using the white ethernet cable. Could that have been one of the issues?

Unless it wasn’t captured on your first video, I don’t think the RPM was exhibiting any power issues.

We did change the cables earlier but we had the same issue. Power was supplied the entire time, never had the power drop out. Our issue was that the Ethernet stopped providing data. We just tried an older radio and it is working well. Only other possible cause I can think of is the rio not having robot code and libraries installed yet. Oddly, if we ran data directly to the radio and used the RPM to power the radio it worked fine. But if we ran the data and power through the RPM it would stop sending data after a few seconds. Hopefully this helps someone else save a little time.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.