REV Robotics Expansion hub detached error

All,
Our team is facing a random issue where the robot controller gets disconnected from the REV hub throwing an error- REV Robotics Expansion hub detached. Instant Run is already disabled and we are on version 3.5 of the FTC app. It doesn’t happen on every run but it happens once in 4 games. When this error comes, everything freeze and the init button is grayed out. Even when we restart the robot using RC app, it still doesn’t solve the problem. Few times you have to power everything off on the bot to get it fixed.

Has anyone faced a similar issue? Any feedback would be helpful as we are really stuck

I have certainly seen very similar problems with a bad and or poorly strain relieved USB cable between the hub and phone.

If you have not swapped that cable try that. Far less likely, blow out the Rev hub, I saw the hub not power up due to a short caused by a metal shaving, it would be possible you have something in there causing an issue, butt USB cable issues are way more common.

I also recommend checking your USB cable first. If you can rule that out, can you also share a few more details about your set-up:

  • Expansion Hub firmware version
  • RC phone type
  • Status LED on the Expansion Hub color/pattern

Thank you phurley67 and RaMoore. We have ordered 2 new cables and will try replacing the cables as soon as we receive them. Meanwhile here is the information you requested for

  • Expansion Hub firmware version - 1.7. When we purchased the hub it came with 1.6 and I upgraded the firmware to 1.7 after reading few recommendations from other forums (FTC and chief delphi forums)
  • RC Phone type - Motorola Moto G (2nd gen) with Android 6.0
  • Status LED - This is the part we are still trying to understand. Sometimes when the error (hub is detached) occurs, the LED flickers with a pale orange (very dim). It is not the regular bright orange blink that we usually see when just the RC is connected to REV hub and the robot battery power turned off. Sometimes we see the blue light stay on (not blinking). We are not able to establish a pattern of when the dim orange flickers vs when the blue stays.

Appreciate all the suggestions

We replaced the USB cable and still see the issue occasionally. It is very unpredictable and random. Any other thoughts / suggestions

Thanks,
RoboLords

Running out of options. If possible can you swap the REV hub? One of my teams jammed a USB cord into the REV hub and ripped the USB socket right off the board. We were able to keep using it as a second hub (connected via RS-485), but I wonder if they had not been quite so rough, and they damaged it without removing it how long we would have fought with it.

We also had a situation where a bit of our code had an infinitely recursive call, and the opmode would crash taking out the robot controller; however, that does not sound like your situation – but it is the closest I have seen in pure code to the issue you describe.

So my next recommendation, is if at all possible swap the REV Hub and see the problem goes away. If you are already running with two hubs, try swapping which one you connect to using the USB cable.

According to the latest version of the EH getting started guide for firmware update 1.7 in section 2.6

Blinking orange means low voltage – either the battery is low or not turned on and the hub is running off the RC phone power through the cord.

Solid blue indicates everything on the robot is connected and communicating and it is waiting for command from the Driver Station.

Rule out all the cheap fixes before you replace the hub – bad battery not holding charge, bad cord between the battery and the EH, bad fuse (?), bad switch.

And definitely use strain relief on the usb plug into the back of the EH.

Good luck.

Good call, we had something odd with one of our power switches, had to take a file to the contacts to get it to work correctly, was hit or miss at first – forgot about that.

Your app when it is working should indicate voltage, if it is reading below 12V charge/change the battery. Be sure and do a tug/wiggle test on all of the connectors. You should be able to test every wire and not have something fail, if not add strain relief, re-crimp, replace, etc.

Also I am coming from a position where I help three teams, so we generally have extra parts for testing (but not always for keeps), so I am quick to swap parts to see if that is the problem – sorry for making assumptions about where you are at. With that rather large grain of salt, consider swapping the phone too (you can even just swap the driver station/robot controller phones for a quickish test – you will need to re-configure the phones, but you don’t need any extra hardware).

If you haven’t made any progress with it, send us an email to [email protected] and we talk you through some additional troubleshooting.

Our robot did this early on… we fixed it without replacing the cable but putting in strain relief.

This is the one we used:

Works awesome, haven’t had this issue since.

Thank you so much for posting this. People tell me to ‘use strain relief’ but no one has shown me an actual piece of what they use themselves. Now I know what I need to get made. Saves us a ton of work.

We replaced the cables, strain relief etc and none of it solved the problem. Finally we replaced the RC phone to a Nexus 5 and it seems to be working consistently now. Tested the robot for last couple of weekends and everything seems to be working now. Probably the old RC phone USB socket is worn out (can’t think of any other reason). Thank you everyone for all the suggestions.

RoboLords

Glad to hear you got going again. USB sockets will be the end of me, thank goodness FRC season is only 33 days away.

We thought we had everything resolved until we went for the FTC qualifiers on Dec 16th. As soon as we reached the event, we unpacked and got the robot to practice field. The “REV Expansion Hub detached” error appeared on our first practice run and kept coming back continuously. We took help from the FTAs at the event and collected the logs. They also tried to change the Wi-Fi channel but the problem kept coming back. Fortunately we were able to recover from the “Hub detached” error within 5 to 10 seconds and get back in the game. We also observed few other teams using “REV Expansion Hub” facing similar issues. From our experience so far with REV Hub and reviewing some of the blog posts, we are suspecting that there is something in the “REV Expansion Hub / FTC App combination” that makes it think that USB is disconnected when there is network / Wi-Fi interference between DS and RC. Though the logs indicate USB stuck write error, this only occurs in a tournament environment where there are a large number of bots with DS/RC communications. We are sending the logs collected to REV support and any help is greatly appreciated. The difficult part is that it is not reproducible at our home/community environment where we have only a couple of robots.

I’m sorry that you had issues at the tournament with our hardware. We really do appreciate you sending in the logs as it helps us to determine how to fix this in the future.