Riolog not functioning when connected via wireless to router

I run Riolog from eclipse, and it cannot see the netconsole output. Has anyone else been able to get it to work?

If I run tcpdump, I can see the UDP packets coming from the roboRIO, but they’re going to, not

It appears that the default settings on the router using the FRC Radio Configuration tool set up two different DHCP pools with different broadcast addresses. Was this intended?

Note: I’m on OSX, but that shouldn’t really matter.

We too are not seeing any messages displayed on the RioLog when connected wirelessly. * [Note, our laptop is running Windows.]* I have not had time to investigate much yet and plan to try it on a system that was able to successfully view messages on the RioLog last year. We do see the messages printed (with both printf and cout) on the DriverStation log when you select “+ Printing” display option.

I’ve exchanged emails with Kevin at FIRST and he believes that he’s identified a fix. I expect we’ll see an update soon once it has been confirmed.

So it’s a good thing the team resisted my suggestion to write messages to STDOUT as a debugging technique…

Thanks for the information… I will keep an eye out for the update! :slight_smile:

We had the same problem, no riolog output. We’ve taken to ssh-ing to the robot and cat-ing or tail-ing the log file. You can also scp the log file (the name escapes me but you can see the name when eclipse is running the deploy scripts) and save the output.

Next time you should report* a bug so it can be fixed? :slight_smile:

  • Yes, I know there’s not a good process to do this…

Ok, Kevin says there won’t be a Radio tool update until at least next week, so here are instructions you can use to update your radio via SSH if you want this to work now:

  • Radio IP: 10.xx.xx.1
  • Username: root
  • Password: root

Run these commands on the radio once you’ve SSHed in:

uci set dhcp.lan.dhcp_option=”1, 28,10.xx.xx.255”
uci set dhcp.wan.dhcp_option=”1, 28,10.xx.xx.255”
uci commit dhcp
/etc/init.d/dnsmasq restart

has anyone caught wind of when we will see a Radio Configuration Utility update to fix this?

Looks like an updated tool was published yesterday: