Robo Rio 2 image

Hello. We switched out our rio1 for a rio2. Trying to format it following the instructions. Cannot find the rio2 image for 2023. Tried reinstalling the NI tools. Still no image. Only the rio1 image. Thanks.

Make sure you’re following the imaging steps for the roboRIO 2, which are different than the roboRIO 1

Thanks. Yes, we are following the roboRIO2 steps. But there is no Rio2 image when we click on the SD box. Only the rio1 file.

Maybe try uninstalling and reinstalling the game tools? If the file got deleted that should put it back

Ok will try that.

The package manager keeps saying “No Operation to be performed”

Did you uninstall first? If not, the installer will just say “you already have this installed” instead of doing its job

Ok. Didn’t uninstall will try that first. Thanks.

Do I have to uninstall the driver station, dashboard, and rio tool? Or can I just uninstall the rio tool? Thanks.

I am getting this:

Tried a new cable. Now getting this:

From the above linked doc:

Imaging the roboRIO 2 directly with the roboRIO Imaging Tool is not supported.

Use the Balena Etcher method to write the SD card directly from the PC instead (eg not using the RoboRIO).

I really appreciate the help. It now looks like the rio has the image. But when I try to enter the team number using the imaging tool it came back with an error.

Try using the “roboRIO Team Number Setter” tool that comes with WPILib (it should be in the 2023 WPILib Tools folder on the desktop if you’ve installed WPILib).

1 Like

Thanks will try that now.

I sure appreciate your help. Just tried number setter. Still doesn’t look like the number took.

Actually, I just blinked and rebooted it a couple of times and it looks like it is there.

Thanks so much! Really appreciate you sticking with this!!

Hello. I am now getting a red com light on the rio. The driver station says there is com.

A red com light indicates that there is no robot code running on the rio, which is consistent with the screenshot of the driver station you posted. You must redeploy code after you maging the rio.