Roborealm values cannot be accessed by our code

Hi all,

 As Week 5 comes around, the stress is on to finish all of our code and our biggest hurdle right now is CAMERA CODE. We've tried some methods found on ChiefDelphi's threads and none of them seem to work. 

The methods we have tried are:

  • Took out the // in the prefix of the Network_Tables Module.
  • Changed our Hostname to roborio-2265-FRC.local

Our current code is:

NetworkTable table;
table= NetworkTable.getTable(“SmartDashboard”);

public void teleopPeriodic() {

    double height= table.getNumber("IMAGE_HEIGHT", 10.0);
    table.putNumber("IMAGE_HEIGHT", height);
    SmartDashboard.putNumber("HEIGHT", height);

The picture attached below is the modules we used to isolate our goal and the variables we tried sending to NetworkTables. The variables can be seen on Network Tables Viewer but our CODE can’t access the variables.

I suspect that this is a small problem that we just haven’t caught in quite a while. Any help is much appreciated and feel free to contact me at [email protected]

Good luck to everyone!


Have you gotten any answers? My team is having the same problems.

MY Team is ALSO having the same problems, only with a Raspberry PI.

We can see the NetworkTables in the LabView dashboard, but according to the code on our RoboRio, our “GRIP” Table does not exist.

We also tried sending the values to a Sub-Table, and just writing the variables in the SmartDashboard table.

No matter where we put them, the LabView dashboard COULD see them, and our RoboRio code COULD NOT.

Any help would be fantastic, our team is completely stumped.