roboRIO 2.0 imaging no targets found

I have flashed my sd card on both raspberry pi imager and belenaEctcher, but the status light on my roborio is still flashing red. I’m certain I have the correct usb cable (2.0 type a to type b male). (This is what pops up:
image
I’m not sure what to do.

You need to follow the roboRIO 2.0 sd card imaging instructions: Imaging your roboRIO 2 — FIRST Robotics Competition documentation

If you’ve already imaged the sd card and booted up the Rio, you can use the wpilib team number setter to set the team number. I’ve found that to be more reliable than the imaging tool.

You might find it useful to try some of the troubleshooting suggestions for the roboRIO 1.0. In particular, I have observed that people often fail to perform the “Disable all other network adaptors” step.

1 Like

The status light blinking red means there is an error, and since you have tried reimaging your sd card, have you tried going into safe mode and updating the firmware there?

This can’t be done on the roborio 2. The only way to image is via the sd card.

What is the file name of the file you flashed?

UGHGHGHGH
this is the file I’m flashing.

You need to use the roborio 2 image- it’s inside the “SD images” folder.

3 Likes