RoboRio 2.0 - No Robot Communication

I’m attempting to setup our new rio 2.0 but am having issues. I have imaged the SD card with the FRC_roboRIO2_2022_v3.0 image. I can open the “roboRIO imaging Tool” to check this. I then use the game tool to set our team number.

I imported our 2021 code I made in November/December to the 2022 and fixed it up. I can deploy the code apparently.

However, when I open the driver’s station, I get “No Robot Communication”. The Wifi, USB, and Firewall icons are all lit green on the station. This is when connected over USB. When connected over wifi and USB, the Robot Radio light is green.

Any ideas for a fix?

When you deploy the code, do you get that “Riolog” panel, and does it start giving you console output.

Make sure you set your team number in the new driver station.

I do get the window popup but no text flow

Yea that was one of the first things I checked. No go

We are having this exact same issue. @P33ge - did you find a resolution?

Unfortunately, I cannot remember what it is and to my frustration I did not post an update here. Most likely it was as simple as a computer restart. Triple check you have the updated NI Game Tools installed and the newest WPI update.

I’ve seen multiple instances of corrupted SD cards on a few teams. Though I haven’t heard of that happening during initial setup before. Have you tried a different SD card?

All you need to do is after you image the sd card, put it back in your roborio start it up use the usb-b port on the bord to connect to your computer then you need to open the roborio imaging tool, go to "edit startup settings " then add your team number and then apply it, this worked for us.

2 Likes

Some possible solutions that you can try out since my team also had this problem today when we were re-flashing our roboRio 2.0:

-Get a new micro SD card and flash the latest new image (We used a new 64gb micro SD card)

-Power cycle the robot, and connect via USB - type A onto the robotic imaging tool to reformat the micro SD card to your team number

-Press the reset button on the roboRio after you plug the micro SD card

-Check if the LED on the roboRio for Power/Comm is green

-Once deployed, the “Riolog” panel should pop out in the WPILIB extension with a new tab on your left, to see if your connected to the robot and has successfully push code.

-If you are importing an old project to a new year in WPILIB, perhaps the template you use has changed and some of the imports have been deprecated, It’s best to make another template and to make sure you’re able to deploy a regular template, and then make another template and slowly one by one take the old code and putting it in the new template for your robot code.

-Please refer at WPILIB to see the things they Deprecated/Add for the new year that potentially that could break your code:

@Fan_of_things you nailed it! We had to reconnect to the rio 2 to set the team number after burning the SD card. (We just moved over to the rio 2) thank you so much.

2 Likes

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.