roboRIO 2.0 SD card orientation issue

Here is a video documenting an issue with the SD card slot on some roboRIOs. (This is a problem with our roboRIO 2.0 let us know if you have the same issue).


So it’s a tolerance issue with the push-to-release microsd socket when in that orientation? Seems easy enough to work around, but good for teams to be aware if.

Have you contacted NI about this?

We have not contacted NI about this yet. We just found it out today and figured we would share our findings so other teams could avoid the mistake we made.

Can you qualify this for me? What does “some” mean? Is this something you’ve heard/discussed with other teams? Is it something you’re seeing with yours so you’re expecting it’ll impact others? Is there anything that would make you think it’s some and not all?

I’m trying to get a better feel for what you’re seeing as it’s the first I’ve heard of it =)

Here’s another team with similar issue: Have you had issues imaging your RoboRIO this year? - #9 by wits


I’ve heard about enough teams having issues that this definitely isn’t isolated to a handful of bad products. It’s a fundamentally poor design of the microSD card slot which is incorporated into all roboRIO 2.0’s. The issues are concerning enough that I would strongly consider running a 1.0 this season.


When my roboRIO 2 first arrived the SD card was stuck in the slot and I had to disassemble the case to get it out for imaging.
The slot behaved properly after that.
I don’t have any issue with removing the card in any orientation, so the solution may just to be enlarge the case slot slightly in the direction it’s sticking.

1 Like

Interesting. That is also part of the reason we put this out was to see if people had the same issue and/or fixes that work.

1 Like

So, when the card got stuck, there was still a “springiness” and it was getting caught on the case?
When ours got stuck, there wasn’t any “springiness”. Glad to hear yours behaved properly after the initial issue.

We’ve had issues with 2 RoboRio2s with cards getting stuck in the slot and then being removed with a needle nose/'tweezer or removing the case. Other times (we had mounted one upside down on a robot), the card just fell out.

We’ve been able to successfully image one of the two RoboRio2s that we have, but the other is just a big paper weight. We’ve tried several cards besides the one that came with it. It doesn’t seem like we can get it to seat correctly to read the card (or the reader doesn’t work). One of our mentors is contacting NI.

In any case, I’m not fond of the new RoboRios because it seems like a horrible failure point (card falls out or won’t seat correctly to be usable). Maybe its because the RoboRio1s were dependable. The only issues we ever had was self induced (somebody drilled over the robot without covering it or using a vacuum and we ended up with metal shavings in one of the ports causing a short.)

1 Like

No. No springiness.


Appreciate you. It’d appear I haven’t been watching enough of the hardware threads so missed the chatter. I’ll poke some folks.

NEW UPDATE** when the roboRIO 2.0 is mounted with the SD card slot at the top you can eject it but not insert it.

I just heard back from our manufacturing team.

They tell me they did a bunch of tests and saw similar behavior. They’re placing a white sticker on the SD cards when they finish the burn to let themselves know internally the card is ready for testing. This sticker, while thin, is changing the sizing of the slot enough that they saw much better results after removing the sticker.

It’s a sticker that’s just there for their internal process (and they’re looking at fixing that process to not have the sticker in the future). It’s something you can remove and they saw normal results after that.

If you remove the sticker, do you still see issues or does it act as we’d both expect a SD card slot to act? If it’s still having issues, I can push that feedback along.


We had issues with this same issue. However, rather than being able to simply change the orientation of the RoboRio, I believe our SD Card slot is now broken. No matter what we do it will no longer hold the SD Card.

What sucks is that we are at our first event and the reason we were updating is that we are required to move to 2022.4 :frowning:

We’ve had a lot of issues with the SD card slot on the RoboRios we have purchased.

In spite of this, we ended up deciding to put a RoboRio 2 on our comp bot. Last night while doing driver practice, we wanted to deploy some changes. The battery was low and deploying code failed. Then we realized the RSL wasn’t lit. Swapped the battery with a fresh one and when we powered on the robot, the status light continually flashes (unrecoverable error). So we tried booting in safe mode, but it still was flashing indicating an unrecoverable error. We tried:

  • reimaging the SD card
  • replacing the SD card with the one that was working on our practice robot

Both didn’t resolve the issue. And in the end we believe the SD cards weren’t seating properly as the “springiness” was gone.

We’ll try removing the sticker, but given that it was seated and working fine before the rio went to this unrecoverable error, I’m not sure this is the issue.

I’m not looking forward to something like this happening at a competition.

Did any teams have this issue recently with their new batches of roborio 2.0?
We are currently experiencing similar issues of not being able to push an SD card down to the point where it’s held by the slot.

Like this?

Have you tried removing the white sticker on the SD card? That’s what NI said we should do. :wink:

We had to use another SD card without the sticker (because we lost the card :frowning: )

Oops… The only real loss there is the card NI ships is using PSLC flash and not just MLC but that likely doesn’t matter a ton - just make sure it’s a quality card from a major vendor (Samsung, Western Digital, SanDisk, etc).

The little white sticker isn’t the problem (it never really was but I’d be shocked to find an engineer at NI who will admit it to me). The little white sticker measures at like .08-.09mm thickness and even with the card, it’s less than .803mm thick which is the max size for the MicroSD card spec (.603mm to .803mm with .703mm being nominal).

The core issue here is the MicroSD card slot being used on the RIO 2.0 is using a push/push mechanism and they are prone to failures like this, particular this sort of vertical variety that isn’t mounted flat to a board… it’s got to do with how the mechanism operates and how much play exists in it.

Now… how to fix it. The right way is to use whatever support process NI has now for getting a replacement that hopefully doesn’t have this problem.

The not-so-right way is to ensure the spring mechanism is failed such that it isn’t ejecting your card - which will eventually happen all on its own if you keep pushing on it… it has for 3 of our 5 RIIOs at this point. Once that happens, you can only insert/remove the card by opening the RIIO but you only need to do that once a season or so. It’s a small price to pay for ensuring the card never comes out when you don’t want it to.