Roborio 2 and labview

We are still struggling with using the Roborio2 with labview. Everytime we download our program to the Roborio 2, it crashes on our laptop. We were part of a discussion in a previous thread about this issue, but I had not seen a resolution to the problem.

first the list of dumb questions:

  1. have you installed all the updated drivers? this includes the NI fix to install the CRIO drivers?
  2. have you installed the newest FRC game tools and flashed the newest firmware to the SIM from March 3rd?
  3. if you are using CTRE components, have you used the Phoenix Tuner to load the recent CTRE drivers onto the RoboRIO?
  1. We have not done anything since mid-February with it. (we went back to using the old Roborio). I was not with them last night so I can not guarantee anything they did/did not do. I will have them start there tonight.
  2. No CTRE components.

When you say “it crashes on our laptop”, you’re saying LabVIEW crashes mid deploy?

By crashing/destroying/breaking (you ask different people and you get different adjectives) they mean after they deploy the program to the Roborio, the laptop shows the program with a broken arrow and it gives a netcomm error.

Didn’t NI release a driver update to fix the broken run arrow showing up?

Are you saying that you tried all 3 of the solutions posted below and none solved the issue? If so, I’d recommend listing in that thread for better visibility.

Our team has a similar issue. We haven’t updated any of the drivers. (I think we were hoping that the fix would be part of the recent Game Tools update.) We created a small batch file that “corrects” the LVPROJ file. The two files are attached. Put these in the directory where your LVPROJ file is located. Run this when LabVIEW is closed, then re-open LabVIEW. (806 Bytes)

1 Like