roboRIO 2 Hangs at 80%

Can anyone confirm that they’ve deployed code onto the roboRIO 2? If so, with what versions?

We’ve been struggling with this for the past 3 days. Please send help.

We’ve posted an issue:


We have been deploying to our Roborio 2 since late December successfully (so we used the beta and full release versions). I do not know what versions we are running, but will check on Tuesday when we meet next.

We have been using the sd card that came with the Rio. The first time, it took a long time to format (likemaybe 15 min. If I remember correctly). When we format, we always use the USB port and not Ethernet or etcher (if that is even an option).

Thank you for responding!

We have tried both the roborio imaging tool (with the RIO2 SD card image) along with the card that came with the rio2. When using the imaging tool, we are always connected through USB.

we solved the issue by using WPILib’s roboRIO Team Number Setter tool instead of roboRIO Imaging Tool to set our team number after imaging to the SD directly, which probably didn’t work originally because of an old version of the roboRIO Imaging Tool or something like that.

1 Like

Our team ran into the same issue, and using the WPILib RoboRIO Team Number Setter tool instead of the Imaging Tool fixed it for us! Thanks!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.