RoboRio 2020 Imaging trouble with VS Code

This is team 3559 and we’re having some issues with our RoboRio image working with VS Code.

We’re getting the usual error message that you get when you haven’t re-imaged the roborio to the newest image and firmware, but instead of having an outdated image, VS Code is requesting the 2019_v14 when we have the 2020_v10 installed onto the roborio. The error statement below appears in the terminal when we try to deploy code:

admin @ roborio-3559-FRC.local: Connected.
Reason: InvalidImageException
RoboRIO Image invalid! RoboRIO: 2020_v10, allowed: [2019_v14]

When we ran the WPILib installer for this year, the installer unchecked the VS Code download for this year since we had it downloaded from last year. I don’t know if that could be an issue, but I thought it would be worth mentioning. We updated the WPI Library in VS Code too, so we don’t really know why it won’t accept this season’s image version.

Any help would be greatly appreciated. Thanks!
3559

It sounds like the 2020 version of vscode and WPI plugins failed to install.
The vscode box would have been unchecked when you launched the installer, this is because you need to download it separately with the Select/Download VS Code button.
The 2020 version installs to a different location, therefore you will need to download it again (different version) even though you already have it from 2019.
If you don’t need the 2019 version installed I personally recommend uninstalling it to reduce clutter and confusion.

Follow this guide
https://docs.wpilib.org/en/latest/docs/getting-started/getting-started-frc-control-system/wpilib-setup.html

Did you create a new 2020 project (after installing WpiLib tools), or upgrade an existing project (created prior to installing 2020 tools)?

1 Like

We solved the problem just a few minutes ago by deleting the FRC2019 file underneath the public file on our C: drive. We reinstalled the 2020 version and everything worked fine.
Sorry about the trouble. Thanks for your Help!
3559

1 Like