RoboRio Camera in Dashboard problem

Hi!

One year ago everything worked fine but after update 2017 it’s not work. We use USB camera (MS LifeCam HD) and when we change in dashboard to Camera we still see “No Camera Selection”, but we tried 2017 Vision Example and we see image from camera.
We try reboot roborio, reinstall labview, run dashboard and code on other computer and turn off all anty-virus but it isn’t working.

In driver station We see:
"ERROR -1074360316 IMAQdx Stop Acquisition.viNI-IMAQdx: (Hex 0xBFF69004) Invalid camera session "
and on the other computer after reinstall:
“ERROR 91 Variant To Data in WPI_CameraRefNum Registry Get.vi->WPI_Camera HTTP Connection Respondervi.vi:1340002->WPI_Camera HTTP Connection Respondervi.vi.ACBRProxyCaller.EA60000ELabVIEW: The data type of the variant is not compatible with the data type wired to the type input.”

I don’t know how to repair it, maybe you will have some idea.

We exactly live the same problem. Did you get any progress.

same here! anyone have any suggestions? started with clean 2017 project and nothing appears…

We decides to format computer and re install everything. We are sure that problem not caused by LabVIEW code we used.

Sent from my SM-N920C using Tapatalk

One of the problems was that the address of the camera was not adding the .local suffix. You can fix this by concatenating it to the address in the Send2PC vi.

See this https://www.chiefdelphi.com/forums/showpost.php?p=1648036&postcount=5