RoboRIO Comms issues

Our team has been having issues with 2 of our 3 RoboRIOs this year, when the first one did it we blew it off because we had 2 more.

Recently our last roboRIO started doing the same thing as the other one, and our only good roboRIO is bagged with the bot.

The RoboRIO seems to be running fine, we can SSH into it from USB, web dashboard works over WiFi and USB, NetworkTables runs fine (it even passed GRIP numbers from the kangaroo plugged into the bridge to the driver-station PC on WiFi and USB), and we are even able to upload code and see that the code is running (program logs, on both WiFi and USB). The only issues are that we cannot connect to the RIO with the FRC Driver Station (both the normal comms light and the diagnostics one) and that we cannot image the RIO no matter what connection type we are using.

We have tried our normal driver-station laptop (Win10, firewalls off, USB, Ethernet and WiFi). We also tried our kangaroo (Ethernet to the same bridge as the RIO), and we tried our older driver station laptop (Win7, firewalls off, USB and WiFi).

EDIT: We were also had the Robot Radio light on, and were able to log into the radio to see that it was there. We are using an old DLink for the radio on our second bot because we fried our second new bridge.

Things I’ve assumed you tried but I’ll run down the list of what I’d try anyway.

  • Running some form of default code, one of the example programs or something like that.
  • Uninstalling and reinstalling the drive station package
  • Installing the driver station on a new laptop
  • using a known good laptop and drive station installation from another team, etc.
  • changing USB cables (we have had cables that don’t let us image)
  • unplugging all devices form the roboRIO prior to imaging, MXP port, IO, etc.

Have you imaged the Dlink radio using the 2016 software?

We know the code is running, the log from the program shows us that. We will try a default code later if all else fails.

We have tried 3+ computers, all of which were working and now aren’t.

The USB is working, we can SSH into the bot but no comms on the dashboard, and we did reimage the Dlink.

To me it seems like a issue with the FRC comms stuff on the RIO, yet NetworkTables, SSH and other things still work.

I understand that the USB is working, I’m suggesting that you change the cable anyway because we had a cable that would let us drive the robot but not image the roboRIO. I don’t know why but it never worked with that cable. All of my suggestions are to try to find the illogical solution since most of the logical ones you already tried. I’d try default/example code as soon as possible that’s one of the first things I try just to verify it’s not something myself or a student did in code.

For all those wondering and who had similar issues. We contacted National Instruments and they were able to guide us through the process of making a USB recovery flash drive that we then used to boot the RIOs on. From there we were able to upload new firmware, and then image them.

Both of our once broken RIOs were fixed in this way, and if you have tried to image and upload new firmware to the RIO and weren’t able to do that while the RIO was in safe mode I suggest you contact NI ASAP.

Help! Our RoboRio is having issues. Does anyone have schematics. Here’s what the fix-it guy is saying.

“F3 puzzles me, but I have not run into a smd fuse like it before this,
it appears to be open across the traces, but has continuity across the metal tabs on top of the device. I cannot get continuity from the top to either pad on the pcb. it is marked 2 with an underscore under it and N under that.”
Any assistance would be great.