RoboRio Communication Issues

So a group of 4 guys including myself have been trying to figure out for the last 2 1/2 hours why our RoboRio isn’t wanting to communicate with us. I know for a fact that there’s an issue with the communication between the RoboRio and the radio itself because of the fact that our Radio LED is displaying nothing. We’ve tried several different methods in attempt to fix the communication however to no avail. Our PCM, PDP, RoboRio and the 6 Talons SRXs that are being used on our robot are all up to date with their firmware along with re-imaging the RoboRio 3 times. As of right now, my team is currently stumped and I on behalf of them is reaching out to anyone willing to help us come to a solution to this conundrum. Thanks in advance.

  1. First, test using the radio Ethernet port closest to the power connector it’s labeled POE.
  2. Which of the Driver Station ping indicators are showing green on the Diagnostics tab?
  3. Are both the Driver Station Communications and Robot Code lights red?
  4. What are the Ethernet status lights doing on the roboRIO?
  5. Can you browse to the roboRIO over USB and check the IP address it is using?
  1. Robot Radio and Robot are show green in the ping indicators
  2. No, Communications is green while Robot Code is red
  3. When communicating over wifi, the yellow LED quickly flashes while the green LED is solid
  4. I have done that but when I attempted to connect to the RoboRio via Labview, I would still get the same communication error as to when I remained in 802.3af.
  5. Yes the two IPs that it has listed are and

From the statuses you’ve described it sounds like your PC communicates just fine with the roboRIO.

Is it just a problem with LabVIEW that you are describing?

Are you attempting to Run from Robot Main?

Are you able to use Build Specifications to Build and Run as startup?

Is there something else important that I didn’t catch from your descriptions?

Firstly, I don’t believe that it is an issue with the LabVIEW beings as though that I was able to get the code to work on our kit bot before we re-mapped the electronics to accommodate for the restrictions on our official robot. Secondly no I have not been running the code from Robot Main however I have and will continue to connect to the RoboRio in the VI tree before deploying any code what so ever. I am able to use the Build Specifications to Build the code. I am however unsure on what you mean by the phrase “Run as Startup.” I’m wanting to say that you are referring to deploying that build to the RoboRio and being able to run it just fine however again I’m not exactly sure on what you mean by that. Finally, I don’t think you have missed any details that I have mentioned in previous comments. I can ping the system however I just can’t get it to respond to anything that I request it to do. One of our guys is saying that their could be the possibility that the board is dead in some ways but I personally don’t think so, I simply think that there’s a communication issue that’s going on between the radio and the RoboRio because I can ping both the modem and the RoboRio just fine but simply can’t connect through LabVIEW.

“Run as startup” is the name of the selection in Build Specifications that we normally use to transfer the LabVIEW code that has been built (on the PC) to the roboRIO.
See “Deploying the Code” here and it describes it:

If you can ping the roboRIO, then you have basic hardware communication all the way through.
If the Communications light is on then the Driver Station is successfully communicating with the FRC code communications task running on the roboRIO.

The Robot Code light being red means there is no user program running on the roboRIO for the Communications task to talk to. (Maybe because "Run as startup hasn’t been used yet).
Nothing will respond until you successfully get your code onto the roboRIO and you get the Robot Code light to turn green.

Okay I’ll see what I can do about it tonight. Thank you for your input, it’s been quite helpful.

Okay so I’ve attempted to do what you had defined to me just now and I’m still getting the same issue where LabVIEW will tell me that there’s an issue communicating with the RoboRIO but gives me no error code what so ever to work with.

In the LabVIEW project explorer window (the main project window) check the name in parenthesis after “Target” to see if it’s correct.
A mistyped team number would be a simple cause for LabVIEW not finding the matching roboRIO.

For your team it should read “Target (roboRIO-753-FRC.local)”

The other thing to try is to connect the PC directly to the roboRIO using a USB cable and trying to send the LabVIEW code over that path.

The electronics guy and myself spent a couple hours last night trying to figure out the issue and what we discovered was that there was something wrong with the project file that we were using. For some unknown reason, the project was the one causing the problem and I’m still going through the process of trying to retrace my steps to a point of possible origin for the problem. Again thank you for the input it has been quite helpful.

We did attempt those solutions when the issue first popped up but of course the problem has been “resolved” for the most part.

Glad you found out what was causing it.

Good luck!

My team is having the same problem, but I don’t see how it could be caused by the code because nothing seems to be able to communicate with the RoboRio at all. Only the Power indicator on the side is green, status (switching on and off) and RSL are orange. The rest are turned off and we don’t seem to have any access to the robot. No communication is taking place as far as we can tell.

Only Robot Radio is green for our team. Robot is red.

Try using a USB cable between the laptop and roboRIO. Check that the team number enterer on the DS Setup tab is correct. Also click on the arrow next to this field and see if the robot is listed along with its IP.

If the USB cable doesn’t work, in a windows cmd window, type ipconfig and see if the interface shows up. If these things are present and it isn’t working, please check the firewall again. Turn it off entirely.

If USB works, but ethernet doesn’t, please check the laptop’s control panel. Drill into the adapter settings and see that the laptop is set for DHCP.

Try the ethernet cable directly between the laptop and roboRIO and also try with them plugged into the robot radio.

Please report what you see and that will help identify the issue.

Greg McKaskle

Okay, so…

Ipconfig returns that is there, along with what should be our robot IP from a wired connection. The firewall is disabled.

Neither USB nor ethernet work, for some reason DCHP was disabled but troubleshooting fixed that and now this computer can actually connect to the internet. The RoboRio has not changed in status, however.

If interface is there, can you ping Do you have both ethernet and USB connected at the same time? Try pulling the enet cable.

Can you ping roboRIO-####-FRC.local or .lan? Does the web browser with bring up the roboRIO web page showing you the IP settings of the RIO. That would be a good page to see a picture of.

Greg McKaskle

I ended up going to that webpage and found out the IP was something like and the driver station was trying to connect to something that didn’t exist. For some reason the RoboRio just decided to randomly erase itself or something; re-imaging it solved the problem and it’s been running fine ever since. Thanks for the help!