Roborio connects wirelessly but not wired

Our roborio has mysteriously stopped connecting to our laptop through a wired connection. It still works fine wirelessly through the radio but does not work with the usb printer cable.
So far I have tried:
*3 different wires
*a different roborio (other rio worked perfectly with same wire and laptop)
*powercycling/resetting the rio

Right now I’m thinking its just physical damage. The last thing I did was flash the radio program but I’m not sure that had anything to do with it. Any suggestions would be appreciated.

Over USB, are you able to use a web browser to go to

Try using a new USB cable?

Already tried 3 different ones

Will try and report back during next meeting

Is there physical damage in the usb port on the rio?
Does connecting over ethernet directly to the rio still work?


Just a guess, but check for metal shavings in the USB port.

If you have a spare roborio install it and see if you have the same issue. If using 2.0 try the older roborio

I suggest checking the windows defender firewall settings on your driverstation computer. The firewall is independently enabled/disabled for “Domain” networks, “private” networks, and “public” networks. When you first hook up to a network you choose which of these classes will be used for that network. It is entirely plausible that the USB network and the WiFi network are in different classes. The status information on the task bar, I believe, will show its warning about the firewall being disabled if it is disabled for any of the classes, lulling you to think all is well. But it can be enabled for the class of network that you care about at the time. To see the status for all three classes, find the settings page “Firewall & network protection”. Turn off the firewall for all three classes.
We have had this problem with a driverstation moved from one robot to another – worked with one, didn’t with the other; because one wifi network was in one class and the other was in a different class.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.