RoboRIO corrupt firmware when flashing 2022 image

Hello all,

I am having trouble flashing one of our teams RoboRIOs. When I tried putting the 2022 image on it, it gave me an error saying the firmware was corrupt, so I tried to reflash the firmware, but then kept running into this error:

I’ve disabled all the antivirus and firewalls, restarted my computer, ran the image updater as an admin, and started the RoboRIO in safe mode. I’m plugged in directly over USB to the Rio as well. The roboRIO doesn’t give an unrecoverable error light either.

The weird thing is just before this, I was able to flash another RIO with the 2022 image just fine.

Any ideas?

Try a different USB cable. That’s been one of the causes of this error before.


I’ve been running into the same issue with the corrupt firmware. I found a few old threads on the NI Forums that described the same issue (Solved: roboRIO Firmware Update woes - NI Community, for example). In those cases, the fix was apparently getting a recovery image from NI.

I’m going to try using a different computer and cable next meeting and see how that goes.

1 Like

Will try that tonight,

Thanks Mark

Is this for a RoboRIO 1.0 or a 2.0?

1 Like

My team had the same issue with the RoboRIO 2.0. We were able to remove the MicroSD card and flash the firmware onto that. Make sure after that is done to go back into the imaging tool and modify the startup settings to set your team number, because evidently just flashing the MicroSD doesn’t set it for you.

1 Like

RoboRIO 1.0

Yeah - check the USB cable and if you can, find a different computer to run it from.

As @Jbkerns just mentioned, the 2.0 seems to prefer/need to be done via the SD Card flashing method.

1 Like

There has to be something up here right? It might just be experience bias or something like that but I feel like there has been an uptick in RIO bricking issues in the last few years since 2020 when trying to image RIOs.

Are there any specific steps we can take when imaging our RIOs to decrease the likely hood of this happening? (besides using the sd card, we only have RIO 1s)

We did the same. (Flashing the SD from a computer. I am thinking that is generally true for flashing the SD card for the first time. After that you can do it from the Rio. Also make sure you have the image for the Rio, not the PI. It was not productive asking my programmer how he knew that. This is obviously for the Rio 2 and not the Rio 1.

A couple year agos, the bricking off the Rio and needing a recovery image that NI posted it to the CSAs.

This has not been my experience so far.

Could be. We just started playing with our RIOs last week. But then we are not putting Doom on them either. :slight_smile:

I’m really hoping someone else tackles the great RoboRIO 2.0 thread because there are some peculiar consistent inconsistencies that teams might want to be aware of.

I switched the cable and it seemed to work! Thanks everyone

1 Like

Same issue here. Going from a 2020 image to a 2022.

Nothing worked. I switched from USB to Ethernet and that did not work well. It struggled to find the roborio.

Once I did find it on the network somehow (I think I toggled DHCP <-> Manual IP in windows), I tried to update it. It got further along then failed

I restarted the roborio, tried again, and failed. I noticed after this attempt, the image version was updated but the team number did not stick. I tried a few more times and that failed.\

I ended up updating the firmware afterwards just to see if anything would work. That was successful, and set the team number

Code deploys and it seems the roborio works normally

Update: tried a different computer and cable and everything went well. Thanks to @Mark_McLeod for the fix.

Any other thoughts? We’ve swapped computers, usb cables, flashed the microSD card independently and then tried setting the team number after that. Still getting errors with bad image. Even tried reloading the gametools, thinking maybe that got corrupted somehow.

We’ve had microSD cards fall out as well as get stuck in our 2 roboRio2s. I’m starting to dislike the RoboRio2 as much as I dislike the radios. Too many failure points.

Maybe try the NI forums?

I’ve been trying to put my team number (in imaging tool)(this is for the roboRio 2.0.
It’ll say {unable to configure the settings…error 2147220622


I’ve also used the SD card and that seems to be able to work, just up until I put my team number