RoboRIO deployment issues that persist across reimages

Ever since we got back from FOCP, I have not been able to wirelessly deploy to our RoboRIO in Java, C++, or Python. I have run out of things to try.

My laptop is running Ubuntu 18.04 with the latest Toolchain, and Java installation.

To save some time, here is a list of things I have tried

  • Reformat RIO
  • Reimage RIO
  • Re-load firmware on RIO
  • Reimage Radio
    • Tried enabling and disabling firewall
    • Tried enabling and disabling bw limit
  • Manually deploy over SCP and SSH
  • Enabled Offline deploy
  • Disabled offline deploy
  • Used a different team number
  • Changed our mDNS address
  • Tried using the field mDNS addresses
  • Disabled UFW on my laptop
  • Enabled UFW on my laptop
  • Set UFW rules to allow all traffic on SSH, HTTP, FTP, and port 1742 (used by driverstation if i remember correctly)
  • Tried deploying over our shop’s FMS network

I also cannot even ping the RIO. I get a Bad Gateway message from 10.50.24.1. Although, The robot can be controlled with driverstation (on a different laptop (windows 10) , over he same wifi connection).

Here is our on-robot networking configuration:

Radio -> RIO
Radio -+
       |
       +-> Ethernet Switch
            |        |
            |        +-> Raspberry Pi
            +-----> Secondary Laptop

The second laptop (ubuntu 18.04) can successfully communicate with the RIO.

Is the WPIlib extension for deploying code up to date? We had that problem for a while.

Yes. So is GradleRIO.

I also have the same problem with the RobotPY deploy tool when using Python.

Also, I can still deploy over ethernet

When you reimaged the radio, did you check the Firewall box? If so, you will not be able to deploy code wirelessly, as that option blocks ssh and the ssh ports.

1 Like

I don’t think so. Would this also block pings?

No, it would not block pings. Pings not working is indicative of a lower level networking issue. What address are you trying to ping? mDNS or static? Is the RoboRIO set to a static IP?

Since a Windows laptop and your other Linux laptop both work, it is probably something with the setup on your particular laptop. When you are connected to the robot wifi, what does “ifconfig -a” output on the laptop?

I will check ifconfig tommorow.

I have tried pinging both:

  • 10.50.24.2
  • roborio-5024-frc.local

Neither are working, but both worked fine before FOPC

Did you change the physical network layout before? We’ve had funky issues when using the second radio port before where certain types of traffic were being completely dropped.

Which port of the radio is the RIO connected to and which port is the switch connected to?

If it works over the Ethernet, but not wirelessly, I would look at the radio. Worth re-imaging the radio. Also be sure your computer has a IP on the same subnet as the rios.

The radio has been reimaged many times, and I made sure it is not the one i killed from overvoltage. Everything should be the same. Im going to check on my break today.

No changes where made between FOPC and now. We where having issues with taking literally 30 mins to get a DS link when wired at the competition (Sorry robot inspectors).

The RIO is in the correct port according to screensteps and is going through a POE injector (which was the source of our ethernet issues throughout the season, but that was fixed)

It seems like there is some weird firewall. But I cannot figure out where it is. Our other two robots are currently not working, so I cannot test their hardware to see if it is my laptop right now.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.