Roborio doesn't connect to the driver station over wifi connection

Team 7201: Our team is having issues with connecting to roborio board over wifi. We connected our laptop to OpenMesh radio using wifi, and the radio is connected to the roborio using ethernet cable. With this setup, the driver station is showing red light next to the communication indicating that there is no communication established. The roborio has its comms light turned off which also means that the communication is not established.

We tried: reimaging the roborio, reconfiguring the radio, reformatting the roborio, changing the ip of the roborio to “static”, “local only” and “dhcp or local only”.

We tried connecting the roborio to our laptop using ethernet cable, this didn’t resolve the problem.

We checked the ethernet cable and it works fine when connecting to a normal home network.

We managed to connect the comms directly to the laptop using USB-B cable. When we did this the light next to the communication in driver station was green, and the indicator on the roborio was red. Meaning the connection is established but no code was running. And that was fine since we didn’t upload any code.

We are still experiencing this issue over the wifi connection and if anyone can help us resolve this we would be very thankful.

Best regards, Crobotics team.

1 Like

After you uploaded code and reconfigure the radio, check in your driver station settings to see if your team number in there matches what’s configured for your radio. That’s the only remaining thing I can think of that you haven’t already checked.

As usual disable all local firewalls and stuff.

We did disable all firewalls and antiviruses and the team number is set in the driver station.

A few things you could try:

  • Make sure in your Network Adapter Settings (Control Panel > Network and Internet > Network Connections) that your WiFi network adapter was re-enabled after you configured your radio.
  • When you configure your radio, make sure you are not configuring it to any kind of official event firmware; this will cause the radio to not allow any WiFi connections. Also try configuring to an earlier firmware version.
  • Consider testing this on a different laptop to see if it is able to connect to the radio; it could end up just being an issue with this particular laptop.

Tried 2 different laptops. In both cases we re-enabled the wifi adapter and still nothing worked out.

That’s odd. Perhaps try uninstalling and reinstalling the Radio Configuration Utility. When you run the configuration utility again, first load the firmware, then run the utility again and configure. Make sure the firewall checkbox option is not toggled. Also make sure that, during configuration, the radio is connected to the laptop via ethernet and the ethernet cable is plugged into the leftmost port on the radio.

Kind of a long shot, but have you tried replacing the microsd card in the rio with a new one? They get really screwy when the sd starts to corrupt. Just don’t forget to flash it (if you don’t have the flashing utility for some reason it’s in GameTools or installed with WPILib, I forget which).

Check the RoboRIO Imaging Utility (I don’t remember its exact name) and configure it’s team number to be your number. We had this issue once when we got a robot from a mentor on another team who was leaving FRC and even after changing the team number on the radio and driver station it still wouldn’t connect since the RoboRIO had the wrong team number.

If that doesn’t work, try connecting to your radio and then in powershell or some terminal typing ping 10.TE.AM.2. TE.AM notation is just your first 2 team numbers and then your last 2 so our team (1622) would be 16.22. A team with less than 4 digits uses leading zeros so 254 would be 02.54. Your’s will be 10.72.01.2. You should get a response, if the connection times out there is something wrong. At that point I recommend connecting to the RoboRIO using USB and checking its dashboard (roboRIO Web Dashboard — FIRST Robotics Competition documentation). Once you’re there please send screenshots over on this thread and someone here might be able to catch a problem.

My team had a lot of difficulty with getting the roboRIO to connect with the driver station. A combination of these fixes worked:

  1. Reflash roboRIO with the Imaging Tool. Sometimes, the image on the roboRIO fails halfway while updating and causes it to not connect with the roboRIO.
  2. Reflash radio. Forgot what program we used, but reflashing the radio firmware helped.
  3. The school laptops had restrictive Windows User Account Control (UAC) settings that made connections inconsistently work. Using an admin account made it work perfectly.
  4. Disable ALL firewalls.

If all else fails, I recommend just using or borrowing a laptop. In my case, the problems had to do with the laptop itself and not the roboRIO or radio.

Given that things seem OK when connected to the RIO over USB, the RIO is probably fine. In particular, if the Driver Station has your team number configured, this suggests the RIO also has the correct team number. You can verify this by looking in the panel of the Driver Station which shows some of the networking detail:
image

This link has some really good information on networking. When you switch from USB to Ethernet, the radio becomes a really critical piece of the puzzle. You can start by just using an Ethernet cable to directly connect the laptop to the radio and looking in the same Driver Station panel to ensure you see the radio.

If you try these things and are still stuck, post more detail here and we can go on from there. I also sent a DM if you’d like to do a video call to try to sort things out interactively.

Where is that card? First time hearing about an SD card in a roborio :frowning:

Looking at the picture, I can say that the firewall light is turned on in my driver station even after turning all firewall and antivirus software off. Any advice?

I just discovered that that’s only for the roborio 2. Reimaging on the roborio 1 is done via usb from what I can find. Reimaging still might be worth a shot though.

Tried reimaging but it didnt really help. All tho I did notice there is an error while trying ti load new radio configuration.

Is your wifi turned off when you’re trying to do this?

Yes

Imaging the radio is pretty touchy/tricky. There are threads on just this.

It would help if posted a picture of the diagnostic panel from your driver station, if you can do this.

I think your RIO is likely to be OK, but do be sure you have compatible versions of all of the software – this should be true if you took everything from the same year (2022?) and followed the upgrade instructions. If you can, also post a picture of the driver station panel that shows version info for everything, when you are connected to the RIO (via USB, if this is the only way that is working).

Thanks!

You’ve tried “everything” so anything I suggest will seem to insult your intelligence but be sure to double check your configuration settings as you try different connection methods. Make a table of different connection methods and values needed for each method (IP, subnet masks, dns, etc.) and check off as you configure and try different connection methods. Pay close attention to getting the right IP address, subnet mask, and dns server address that are appropriate for the different methods. They vary and mixing up what configuration is need for different methods results in the bad behavior that you see (I know - I’ve done bad configurations often enough). Simple misreading or typing errors like using 255.0.0.0 instead of 255.255.255.0 trip up a lot of people; check your work!

You said this works:

  • USB from DS to roboRIO works

Try these:

  • Ethernet cable from DS to roboRIO
  • Ethernet cable to radio (which has its connection to the roboRIO) Don’t worry about using that second port to the radio that isn’t recommended. It’ll work well enough for your testing.
  • Wi-Fi from DS to radio (which has its connection to the roboRIO) (Sure you’ve tried this one a million times but be sure to record your configuration values.)

Try these with automatic IP addressing - a DNS has to be provided either from the DS Windows OS or the radio.

Try these with static IP addressing with careful attention to IP addresses, subnet masks and dns address (or not)

I’ve attached my document of how my team configured static IP but you should try dynamic and static in trying to get yours to work.

There shouldn’t be anything new in what we have written here or in my document, that you should have gotten from the WPILib documents.

But I plead with you to carefully organize and document what you have done such that it may then be obvious what step was skipped or miss-typed. And if you still have trouble, the detailed table of actions can be shared with others to get more help.

I am concerned about your imaging efforts and especially those that failed. That shouldn’t happen. And if there is anything special for non-USA configurations, I’m sorry I can’t help with that.

Configuring static IP addresses for robots.docx (2.3 MB)

One of my team’s roboRIO’s Ethernet port died and we have to use a USB-A to Ethernet dongle and plug the USB-A into the roboRIO and the RJ45 into the radio cable. Your tests that pass and fail are consistent with that problem.

I don’t see that you have been able to verify that your RJ45 Ethernet port is functional. Borrow a dongle and give that a try.

1 Like