Roborio Image does not match plugin

C:\Users\robotics\wpilib\java\current\ant\build.xml:227: Assertion failed boolean test.
roboRIO Image does not match plugin, allowed image version: 23

This is a problem that keeps coming up as we attempt to deploy to our prototype.
We have imaged the rio 3 times with the new labview v 19 and have updated our java problems to no avail.

As you have noticed, you can update to 2016v19 as much as you want and it will still fail if your plugins are looking for 2015v23. Install the plugins using either of the methods described near the bottom of this document:

Eclipse will detect that you already have plugins installed and offer to update instead.

It looks like you haven’t updated the eclipse plugins.

When i went to eclipse and checked for plugin updates, it said it was current and i validated with the FRC software site.

So you have the correct version of the plugins installed as confirmed with this page?

If that’s the case, for some reason the plugins must be failing to update the files. Close Eclipse, delete your C:\Users\USERNAME\wpilib directory (where USERNAME is your username), then open Eclipse again.

Make sure Eclipse is set to use the release site, not stable or development. Those are out of date compared to release.

Ok so that did the trick, now im getting error remote command failed exit status 1

Deploy again. Without the entire console output, this error usually pops up because no robot code is running when it tries to cancel the current running code.

Post the full contents of the console window please. That message is not particularly helpful by itself. It means one of a whole slew of remote commands run on the roboRIO failed. Some of them can fail harmlessly, others will prevent the build from continuing, but we can’t tell which one failed or how to fix it without the whole log.

Make sure you are using this years FRCUpdates and that your RoboRio has the matching image.

That should be safe to ignore. It tends to pop up when there is no robot program already on the rio (which causes the kill command to fail)

Deleting the wpilib directory and restarting eclipse solved the problem for me as well. You can also go into the build.xml file and just remove the assertion.

If you’re receiving the error remote command failed exit status 1 but your code is going through and the program builds successfully, then there is no issue. euhlmann explains it well above.

If the error is causing your build to fail, make sure you have the correct JRE on the RoboRIO.

So I also got the exact same error and I did this but it didn’t work, anyone have any other suggestions