RoboRIO imaging error

I’ve updated the 2015 Suite
I’ve also updated the firmware on the RoboRio
When I tried to re-Image it gives an error:

Unable to configure the settings. Unable to comp!ete (not spelled incorrectly) operation because of unexpected error:
Property Node (arg 1) in

We have already tried to Turn it off and turn it back on.

We are having a similar problem. I have been unable to figure out how to factor reset the RoboRIO in order to start over.

We’ve been having the same exact error, we’ve tried 3 different laptops (all W7). I’ve spoken with NI for a few days and after trying an insane amount of things, they ended up shipping another roboRIO but we’re still having the same issue.

The order of installation attempted for the new clean roboRIO:
-Clean install of Labview
-Updated firmware
-Attempt to install (w/ and w/out safe mode) via USB as suggested.

Attempts to get connection over ethernet and wireless have always failed, but USB worked fine after one successful image on the old roboRIO (that was done by a friend’s personal computer over ethernet).

We have tried:
-Changing IP settings
-Using MAX (unable to detect (old) roboRIO as remote system/haven’t tried with the new roboRIO as no reason for it)
-Checked all connections/placement
-Direct connection to roboRIO
-Connection through router wired and wirelessly
-pinging through cmd has worked sometimes
-using Putty (not sure what we did with it)
Will post more attempts when they come to mind.

Did you try rebooting your PC that is doing the imaging?

I don’t remember rebooting the PC. But we used a Windows 8 machine… do you see an issue with that?

Windows 8 & 8.1 were used by some of the Beta testing teams and should work fine.

These issues weren’t encountered during the beta, so the support engineers are working through what may be going on and what may work to fix it.

At this point, there are two issues that they are worried about. If the power connector to the roboRIO were to be loose, the power may be lost during the imaging operation. That complicates the imaging process since it may now be necessary to go into safe mode.

The other issue seems to be related to timeouts during the imaging on some laptops. Please continue to work with the engineers so that we can get to the bottom of this.

Greg McKaskle

How do we contact the support engineers?

How do we contact the support engineers?

Good question. is the primary landing page, but it is sort of busy.

The overview tab contains an FRC 2015 section on the left. It tells you different options for free support. The phone # listed is answered by the engineers.

The third tab leads to the online forums which are answered primarily by the support engineers.

Greg McKaskle

I got hit with the same problem with a roboRIO and PC that had been imaged a couple of time with beta (roboRIO was not a beta one, was one of the AndyMark early deliveries).

What was different this time (besides the versions) was that I had the ethernet cable attached to the roboRIO and a radio (even though I was imaging over the USB). On a hunch, I disconnected the roboRIO from the Ethernet, cycled power on the Ethernet, and the reimage worked.

Don’t know if it was coincidence, but if you have the roboRIO connected to the Ethernet, try disconnecting it while imaging.

Hmmm thanks will give that a try! We had both Ethernet and USB cables plugged in simultaneously.

We had the same problem on Windows 8.1. So we try on other computer that runs Windows 7 and it works. So if you still have the problem try the solution we suggested it may works.

I have downloaded and installed the FRC2015 update but I can’t find any icon or shortcut that leads me to the Imaging tool? I searched c:\Program Files, c:\Program Files (x86) but I can’t find it. Where is it? BTW, we are using Java this year if it makes any difference.

Never mind, I found it. It’s in C:\Program Files (x86)\National Instruments\LabVIEW 2014\project\roboRIO Tool

I’ve managed to fix this error. The laptops I’ve attempted to use are school laptops and they did not have any connection successfully until now. (I’ve only attempted another student’s personal laptop which worked successfully.) The school laptops were running Symantec protection and even if you disabled the settings, they actually wouldn’t be disabled, even though they seemed to be.
FIX: I simply uninstalled the Symantec software and it works now.

We fixed the problem. We used our Classmate instead of my own Windows 8.1 computer and it imaged correctly. It seems it is the OS that is the problem.

Just use the Classmate… :slight_smile:

We are encountering this same error on Windows 8.1, it sounds like nobody else fully resolved the issue? We don’t have any firewall/antivirus on the computer to interfere with the process.

I can confirm Windows 8 and 8.1 work fine. I have successfully used my personal laptop running 8 and the team’s programming laptop which runs 8.1 to image the roboRIO.

Not exactly a solution but…

Instead of re-imaging the rio try uploading the new firmware from the web panel.