RoboRio Imaging failure

I was trying to deploy he code, I found out that the robo rio was not using the latest image. When I tried to image the robo rio, the imaging application failed and said that it didn’t have enough permissions to perform the update. I tried running as administrator, but it also failed with the same permissions error.

are you using a RIO 2.0? I’ve heard of teams have had issues imaging directly to the RIO on it, however if you flash the SD card separately it should work

No, we were using the old robo rio 1.0 from our old robot.

Do you have the license from NI? because that seems like a good first thing to look into if your getting an error like that

Yes, I downloaded a couple weeks ago and logged in with the license. I will re download the NI software on Monday to make sure though.

could you post a screenshot of the error? I can’t tell from your description whether it is a computer error or an error that the roborio imaging tool is giving

also have you tried everything on the roborio imaging troubleshooting advice from WPILIB? Imaging your roboRIO 1 — FIRST Robotics Competition documentation

Ok I’ll send a screenshot on monday

Update, the imaging process worked after rebooting the computer today, I’m not sure what went wrong, but now it worked.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.