roboRIO Imaging Issues

I have not seen another instance of the issues we are seeing with our roboRIO on CD. We have a ticket with NI, but hoped to get a better understanding of the environment. Essentially, we have not been able to update the image on our device. We use C++

  1. Update firmware: no problem

  2. Update image via USB: problem

  3. Tried updating via the Ethernet port and also from another computer but with similar results. I did not log the status light patterns, but will do so later today.

  4. Contacted NI, who provided a recovery tool to use before imaging: same result

  5. NI suggested using NI MAX to format the device before imaging: same result

  6. Attempted to deploy anyway to see if image possibly had installed but received an error indicating authentication problems with lvuser (note: SSH is enabled)

  7. Checked roboRIO via web interface and there is no lvuser account

  8. After a subsequent attempt, the admin account was missing as well.

So my questions:
What accounts are needed for a successful installation?
Are these created during the image installation or as part of another process?
Is it possible that the installation is failing due a permissions problem at a lower level?

I will continue to work with NI but wanted some feedback from you guys.

Thanks,
Walter Everett
Mentor: Team 1758