roboRIO imaging tool not updating firmware

Hi all, I am not sure if this is the right category for this problem anyways, I’m having this problem with our roboRIO.
Whenever I try updating the firmware I’m getting this error:

Any ideas? Thanks in advance for any thoughts, tips or advice.

Which of the 8 possible solutions listed have you tried and what were the results?

1 Like

I recommend following the steps in: FRC 2019 Firmware Update Failing

Maybe a different computer produces a good result. Nevertheless, let us know if it’s not the case. It might also be a good idea to try formatting via Ethernet if we see consistent errors through USB.

@Joe_Ross I have tried pretty much everything on the list, when I put the roboRIO into safe mode it doesn’t show on both computers we have.
@oscarfonloz thanks I will take a look maybe there is something there that could help.

@oscarfonloz the only viable option I can see from what you sent me is reformating the roboRIO with NI MAX. I will update you guys if it succeeds or fails.
Edit: reformating the roboRIO didn’t work, I used the NI MAX tool. Any ideas?

  1. Have you tried a different computer?
  2. Have you tried using Ethernet (from the computer to the roboRIOs port) with Automatic IPv4 in the adapter (we should see the roboRIO as a link-local address). Do we see the same errors?
  3. Is the roboRIO STATUS LED off when operating normally, and blinking three times when in safe mode? (i.e. we don’t see an unrecoverable error)
  4. When you say NI MAX did not work is because you saw an error in NI MAX or after using NI MAX? More details on what is going on in your side will be helpful to provide better guidance.

You can also use the NI Support line if you wish to speak directly with Technical Support by phone: Connect with NI FRC Technical Support

We’ve had this happen to us at random times. Haven’t been able to figure out what the cause is. Our work around is to boot the RIO into safe mode and then try to reformat it. It sometimes takes one or two tries but that usually solves it for us.

Apparently some teams are having problems because of computer names.


Something like a dash ("-") has to be removed for the utility to work.

This thread has a link to trouble shooting I believe

Hi thanks all, I ended up calling NI tech support for assistance, the technician had me put a recovery file on a formatted USB drive called recovery.cfg, plug the USB into the roboRIO and boot the roboRIO into safe mode. After a few minutes the roboRIO has been restored to factory default settings. From there I could flash the roboRIO.