roboRio imagining uptade failing

Problems In Robot Comm
Our team’s roboRio is connecting to imaging tools but it doesn’t update so we can’t switch to another version.
(We tried ethernet and usb connections and we couldn’t get robot comm connection in both of them and we also don’t have a radio so we can’t make a wireless connection)

What LEDs do you see on the rio when you connect? Does it show up in the imaging tool? Are you giving the rio external power?

The power led is green, the rsl led is red and there are no leds turning on roborio that can be seen in imagining tool by usb but we can’t uptade roborio via imaginig tool for extra we also can’t connect roborio in driverstation by ethernet.

Do you have the rio 2? (You can tell by seeing if it has a micro SD card slot beside the usb ports)

no we have roborio 1.0

Ok, so we can rule out the SD card fun.

Some pictures and screenshots would make diagnosing this a little easier.

Can you take a picture of the Rio status LED’s, and a screenshot of what you are seeing in the imaging tool?

Tried disconnecting everything else but only keep the power to the RoboRIO and use the USB cable. Make sure that the USB port of your computer is in operational state as well. Plug in the USB cable to the RIO and then power on the RIO. The tool only works on Windows (Windows 10 and 11) and not on any virtualized OS (i.e. parallel or wine).

Here its the photo when we start roborio


After some seconds roborio status led is turning off

And these are screenshots from roborio imaginig tool

we tried these way but the main problem is we cant uptade the roborio

Did you tried to Format the Target (RIO)? Do that first with the 2022_v2.x (I can’t remember what was the latest minor version number but you should be able to find off the wpilibdoc site.

We tried all of the things for Format the roborio but we got the same problem and this image

Have you tried a different computer?
Trouble shooting guide mentions problems if the computer has a dash in the name.

We formatted roborio right now with new computer but should we uptade new version and what is the name of new version

I don’t think the 2023 version is public yet. I am not in the beta to know if you need another version. I would stick with what was available with the 2022 tools. I am glad you have it formatted now.

thanks for helping we are going to search firmare versions if we found we are going to uptade it

Uptade: We recieved comms light and its succesfully working thanks for all your helps

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.