roboRIO issues

Last night we changed some stuff in our code. It worked fine then, but this morning when we booted up the driver station it shows that we have no robot code. I have tried re-imaging and updating firmware, we tried different codes, resetting the roboRIO. Is there some other update that we missed, or something we can do? Any help is appreciated.

You haven’t given enough detail for a good guess as to what might be going on. There are a lot of obvious questions that need to be answered. For instance, what programming language do you use? How are you loading the code onto the roboRIO? What messages do you see when you do it?

Sorry for the lack of information. Here goes:

  1. We are programming in LabView.
  2. For our first competition in Week 1, we did not have pneumatics on our robot but have since added them to our practice bot. We took off the RoboRIO prior to bag to put onto our practice bot so we could do some testing, so it is the same part as we used for the competition.
  3. After we added pneumatics, the program worked for us and we had no issues for the past two weeks.
  4. Last night we wrote in pneumatics into our autonomous code and uploaded it this morning. The code built correctly and uploaded successfully.
  5. We are able to connect wirelessly from our drivers station, but it says there is no robot code.
  6. We tried to install our old codes (even back to just a tank drive code) and it builds and deploys but still the drivers station says there is no code.
  7. We have not tried to drive tethered to the drivers station yet.
  8. We did reinstall and update the RoboRIO and still have the same problems.
    9 We install the code using the USB AB cable.

Please ask for more information if you need it. I am the lead mentor, but have nothing to do with the programming. That mentor is currently unavailable.

Thanks in advance for your help.

May be you already know about it, still, in the build specification you have to choose “…Start up…” (bit vague on verbiage, it set as startup or something) instead of deploy.

Do you see the roboRIO (COM)?

Both of these are from the context menu for your rio target:

  • First ‘Build’ the code.
  • Second ‘Run as Startup’

When you say “deploy”, what exactly are you choosing on the computer in order to do it? There are menu commands named Deploy, but none of them are what you should be using. In the same popup menu where you choose Build, you should be choosing Run As Startup in order to put the code on the robot.

Make sure you haven’t turned on the “No App” option on the roboRIO after using the Imaging Tool.

Is your radio still encrypted from Week 1? You have to reset the network settings on the radio otherwise it will be setup to connect to the competition FMS.

Are you able to access the Web UI on the roboRIO (roboRIO-####.local where #### is your team number)?


I actually worked with a team at Pine Tree who had trouble like this. I’m not sure what exactly was wrong, but deploying from another computer solved the problem. Whenever code was sent from the main computer, the roboRIO would not acknowledge the code.

I am the student that found the problem. So I finished building the auto for the code we were currently using. To build and deploy the code this is what I did. I right clicked on FRC Robot Boot up Deployment, then I clicked on build. After the code built successful I then right clicked on FRC Robot Boot up Deployment and clicked deploy. The computer said that the code deployed successfully. I then power cycled the robot and when the driver station connected with the robot it said that there was no robot code. This is what we have done every time we built and deployed code and had zero problems.

We also have two programming computers. I tried to deploy code from both of them and nothing would work like it did in the past.

If there is another way to build or deploy code I would greatly appreciate it.

If you have firewall and/or anti-virus software disable them and try.

I’m pretty sure you’re supposed to be using “Run As Startup”

AFAIK you don’t have to power cycle the robot every time you deploy on the roboRIO.

Your second step will not keep code on the robot after a power cycle. The alternate mode for downloading code, however, fixes this problem.

According to WPI,

In the Project Explorer, click the + next to Build Specifications to expand it.
Right-click on FRC Robot Boot-up Deployment and select Build. Wait for the build to complete.
Right-click again on FRC Robot Boot-Up Deployment and select Run as Startup. If you receive a conflict dialog, click OK. This dialog simply indicates that there is currently a program on the roboRIO which will be terminated/replaced.
Either check the box to close the deployment window on successful completion or click the close button when the deployment completes.
The roboRIO will automatically start running the deployed code within a few seconds of the dialog closing.

This should keep code saved even after cycling power on the RoboRio. However, a detailed link can be found here and has fancy images. (under Deploying the Program)

Deploy does copy the built exe to the controller, but doesn’t mark it as the startup app. This is useful for the user with more than one deployed app. I would prefer to hide it for FRC, but we haven’t gotten to it yet.

Greg McKaskle