RoboRio Issues?

We are having issues connecting to the RoboRio, Ethernet and USB are not working. WiFi is not allowing us to connect either. By process of elimination (switching routers, computers, programs, cables) we think it can only be the RoboRio. Any suggestions?

What is the status light on the roboRIO doing?
Yellow, blinking or off?

You could try booting in Safe Mode.

Can the roboRIO Imaging Tool find the roboRIO?

i don’t know about the statuses of the light but when I ran the utility (Compare project and system) it returned with an error of the target and then showed the RoboRio with a yellow caution icon under it.
I was able to image it after many attempts in safe mode and it worked, after a power cycle I wasn’t able to deploy code to it. We are currently swapping the RIOs out to eliminate it or to prove it is the problem.

The RoboRio was opened by accident a few weeks ago

Opening the roboRIO case isn’t a problem unless you mishandled the circuit board inside.

If it doesn’t have to Bag with the robot, then I’d suggest called NI tech supporttomorrow.
They are a great help.

It’s unlikely each of these components went bad simultaneously. It’s more likely that we’re running into a settings issue elsewhere.

The first thing I’d want you to do is plug in the USB port and watch the lights, as previously mentioned. It’s very difficult to give guided information if we don’t know what’s going on with those lights. As an example, if the STATUS light is flashing continuously, all of these other steps are useless. You need to call NI to get assistance.

If the STATUS light is off, try opening a command prompt and typing: ping

Does that get a reply? If yes, try: ping roboRIO-TEAM-FRC.local with “TEAM” replaced by your team number. Does that work?

If so, try going to roboRIO-TEAM-FRC.local in Internet Explorer (you need Silverlight. Chrome won’t work). If not, try going to in IE. What does the device name say here (assuming the page loads)?

If none of these are working, we’d want to check on the Ethernet connection. Do you see activity on the Ethernet port lights or do they remain off?

If they’re active, at all, we’d want to check subnetting (make your PC obtain an IP address automatically and reboot the roboRIO). Do we see different behavior?

If we’re not getting things to work with these options, don’t bring the radio into the mix. It just adds a layer of complexity. We’ll want to get it working with as few variables as possible.

As mentioned, opening it isn’t a big deal. Often, I’ll suggest that as a troubleshooting step. A lot of teams shave metal over the roboRIO and want to open it up to clean it out.