RoboRIO - No USB communication, but ethernet works


#1

Hello,

We have been developing our software on a practice robot and today we attempted to update the competition hardware. We are unable to communicate with it over USB. We can communicate over ethernet, but doing things like imaging the updating the firmware don’t seem to complete when using ethernet.

It all started by needing to open up the RoboRIO and clean out shavings because we were getting a red power LED. After that the LED was green, but no communication over USB. Is it possible that the USB port no longer functions.

I successfully did a recovery using the NI recovery file on the USB thumb drive. Still no USB.

Attached is a screenshot of the networking while accessing the RoboRIO. You can see the IP address for USB is all zeros. Any ideas? Thanks.






#2

Try updating the firmware on the roboRIO. Your screenshot shows firmware version 2.0.0f2. The latest firmware is 5.0.0f1. Log in to the web interface and click the Update Firmware button. If using Windows, navigate here to find the firmware file:

C:\Program Files (x86)\National Instruments\Shared\Firmware\cRIO\76F2\roboRIO_5.0.0.cfg

Your image (v16) is also out of date so, after updating the firmware, download and install FRC Update Suite 2018.1.0 which was released a little over a week ago. Run the roboRIO Imaging Tool and you should see the v17 image.


#3

Thanks for the tips.

I am having problems imaging the Roborio over Ethernet. At the very end of imaging it i get an error messaging about not being able to download the image.

The web interface will show the latest image even though it errors out. Also when I update the firmware using Ethernet it will also halt saying it lost communication midway through.

I attempted another recovery using a usb drive and the screenshot I uploaded was right after the recovery.

USB communication is how I typically image and update the firmware.


#4

I’m sorry. I missed the sentence in your original post about updating the firmware failing via Ethernet. Have you tried Safe Mode?

Recovering a roboRIO using Safe Mode
http://wpilib.screenstepslive.com/s/currentCS/m/troubleshooting/l/287271-recovering-a-roborio-using-safe-mode


#5

RSNovi,

Seems you’re having the same trouble as the one mentioned in a previous thread: RoboRIO - No USB communication, but ethernet works

I’d advice you to check the steps mentioned there. If you’re still unable to use the USB port, try contacting National Instruments.


#6

Have you ruled out a bad USB cable?


#7

Thanks all for the additional tips.

We have two RoboRIOs. No problems connecting to one with the laptop and cable, but nothing on the ROboRIO in question.

I believe we have tried everything in that other post. Sorry that I created another one but I did do some initial searching.

I am afraid that it might require NI to solve this one.

Chris


#8

We had the same problem. Check under your device manager, in the networking section there should be a driver for a national instruments usb 2. If it isn’t there, there should be a generic usb 2. Delete the generic one with the rio plugged in and the ni one will load up.