RoboRio no voltage?

When we turn on our robot the power light is green with the light under it orange along with the furthest one down,on that string of lights,but after about 2 seconds the second light down turns off and the power light goes red.we replaced the fuse,checked the wires,and unplugged everything except for the power wires and the ethernet wire to the wireless router that wirelessly connects to our computer we use for programming.when we put a ohm meter on it it read 12 volts going in but only 19 millivolts coming out,is it fixable or is are rio fried.(it’s not the wires because when we tried a new rio from another bot it worked fine).

Sent from my iPhone using Tapatalk

The red power light on the roboRIO just means that there is a short on one of the voltage rails. Check all the output pins (DIO,PWM,Analog,Relay,I2C, MXP, SPI) under a magnifying glass for debris/single wire strands/etc.
It will also be caused by any wire plugged into the robRIO that itself has a short somewhere along it’s length.
The roboRIO itself should still work, just not all of the output power pins.

You can also look under the lightning bolt shaped tab on teh driver station to see which rail is shorted. Any non 0 value for the 5V, 6V etc, means a short exists.

If you have still not found the issue after you check all of the output connectors for debris as Mark suggested, there is another thing to check. Remove the roboRIO from the robot and unscrew the 4 screws holding the case together. Hold over a trash can and open up the case. Use a vaccum to remove any debris (from both sides of the board) that doesn’t fall out on its own.

Ok thanks I will try this

Sent from my iPhone using Tapatalk