roboRIO Not Communicating Until Reset

We seem to be having an odd quirk with our roboRIO. When we first power on our electronics board, the FRC driver station does not establish communication with the roboRIO. However, after pushing the reset button on the roboRIO, the driver station establishes communication once it is booted up. We have had to do this reset every time our electronics board is power cycled. Any ideas on what could be causing this would be greatly appreciated.

Are you connecting through the new radio or directly to the roboRIO?

When it is being non-communicative, I have some diagnostics that will help us figure it out.

Please click to the second DS tab and see what the ping LEDs look like. Also look on the third tab to see that the team number is correct. Click on the arrow next to the team number and see if your robot shows up. Shift-click on the arrow and see if the robot name shows up then.

Finally, go to a web browser and enter in roboRIO-team-frc.local where team is your team number and see if the browser can connect.

Please report the results along with what type of interface you were using, USB, enet, wifi. If using USB, also use 172.22.11.2 in the web browser and see if that works.

Also, what type of laptop, vendor and OS?

Greg McKaskle

We were having similar issues where the roboRio would not connect to the router, but no configuration issues with the router or connecting to the router.
Here are the issues we were having: http://www.chiefdelphi.com/forums/showthread.php?t=142140
Basically, it appears that the radio takes so long to boot up so the roboRio is no longer looking for a network once the radio finishes booting up.

**
For us, hitting the reset button on the roboRio does solve the communication issue.**

We tried this type of thing and didn’t have any issues once the roboRio was connected. I believe this to be the issues that we were running into with the radio.

I believe you are correct in thinking the new radio is the issue. I tried booting it up again today, and the radio does seem to be taking a long time to start up.

I have a support ticket in the works with AndyMark regarding this radio. They asked for some diagnostics and I just sent them off a few minutes ago.