Roborio not connecting over USB


#1

We have a rio that is connecting perfectly fine over Ethernet, but it fails to connect over USB. Pinging the rio over USB times out. We need the connection to install the CTR CAN software onto the rio, which only supports USB.
We have tried:

  • Restarting the laptop
  • Running the NI update service
  • Disconnecting the radio
  • Restarting the rio

It is worth noting that when the rio is connected to the computer, it is generating an IPv4 address, but still no ping goes through.

Any advice would be greatly appreciated.


#2

Just to confirm, are you using 172.22.11.2 on USB? 10.TE.AM.75 and roboRIO-TEAM-FRC.local don’t work over USB for us.


#3

Yes, we are pinging it with 172.22.11.2 and the driver station communications status has the green indicator with Ethernet, but not for USB.


#4

Obviously just a couple troubleshooting things:
-Switch laptops (aka make sure whatever laptop you’re using is recognizing the port)
-Switch the cord
-See if you can upload code to the RIO over USB (disconnect ethernet and wireless)

If that’s not working, you could try reimaging. It takes a few minutes but worse comes to worse…


#5

I agree with the previously posted troubleshooting steps. I would perhaps add the next resources for your team:

A) Can you confirm the Firewall in the computer is turned off and there’s nothing (like an antivirus) impeding the USB to be accessed as a network adapter? (go to your control panel and check the Windows Firewall status)

B) Try using the steps provided in this document: Imaging the roboRIO and Common Troubleshooting Techniques

C) If the roboRIO’s USB port is still not responding in any computer, try contacting National Instruments to get more troubleshooting options.

Let us know your results.


#6

Another test that I did (I had this same issue, but the actual USB port was dead) - was to check if the RIO showed up in NI MAX, as it did not at all (not even a generic usb device) - then I confirmed the USB port to be dead on the RIO.


#7

We had a similar problem where the USB device that the RoboRio uses was being not loading the NI driver, but a totally different driver for the same chipset.
We suspected that we had loaded some driver for a different USB package on the same laptop.
It was not obvious what package loaded the foreign driver or how to delete it, so we reloaded the OS and then loaded all the NI packages.


#8

We are having basically the exact same problem. RoboRIO connects over ethernet fine and returns a ping at 169.254.208.130. However, there is no connection over USB, trying to ping 172.22.11.2 does not reach it successfully, and we can only access the web config interface over ethernet and not USB. We also need USB to install CTRE Phoenix framework onto the RIO. Has anyone found a solution to the problem?

Thanks in advance!


#9

Wildcat5e, have you tried all the steps mentioned before? Have you tried with another computer that has the NI software installed?
If the answer to these questions is no, I suggest you contact National Instruments to troubleshoot with them on Monday.


#10

We have tried everything in the thread, including a different computer with the Update Suite installed, to no avail. We were planning on calling as soon as we can (next week), but we’re hoping to make some progress tomorrow, when NI call centers aren’t open. Just wondering if there’s anything else to try that we haven’t thought of already.

Thanks.


#11

Also, to clarify, we ARE able to connect to the RIO over both WiFi (with the radio) and Ethernet, and have even downloaded code onto it and enabled it successfully (although without the CTRE software, it doesn’t know what a TalonSRX is). One thing to note is that every time we have tried to update the firmware (over Ethernet), the RIO disconnects in the middle, showing an unrecoverable error on th status light. Nonetheless, the web configured page shows the updated firmware, but maybe it never actually installed completely. Additionally, we successfully imaged the RIO once, but in all our subsequent attempts to reimage, the imaging tool has shown an error dialogue. If you have any other questons, please let me know.


#12

Update:
Today we continued to try to solve the problem (unsuccessfully) and while we were doing it discovered another problem. Basically, whenever we try to boot the RIO into safe mode, the status light starts blinking showing an unrecoverable error. Using the online config window, we checked “boot into safe mode on startup” to try to recover the RIO, but now, every time you start it up, it starts blinking an unrecoverable error.

The RIO is bricked, and this is especially weird as it worked perfectly over USB all last season and we haven’t used it since. We are going to call NI on Monday to try to get a replacement. Thanks for your help!