Roborio not connecting Via USB tethering

Hello,
Our usual drive station laptop BSODed on us (luckily before the match started and not during). We experienced a BSOD last competition too (FMA NJBRI) but were able to reboot in time, but this time (FMA PABEN) I brought my personal laptop (Dell Latitude E6540) with the National Instrument update suite and everything. We can use it during the match, but when tethering via the USB-B port on the RoboRio, my computer gives off the response of Windows does not recognize the device, and I can’t connect using USB. We asked a volunteer to check it out (official orange cap) and he pinged it and did plenty of things to try and get it to work, but the best he could do was tether via the other ethernet port on the radio. He did many things to try and get it to work, but it didn’t work in the end. :confused: Does anyone have any idea of why this could be happening. I heard that it could be possible that the USB drivers might be missing, but I’ve updated the NI Suite plenty of times just trying in this… please advise!!
Thanks in advance!!
Moiz Sabir-Technician/Electrical Captain 4573

I agree this sounds like a driver problem with the USB connection. Has this computer ever worked with the roboRIO by USB?

There’s a couple of things that can be tried and hopefully bring back the capability to connect by USB with that computer:

  1. Download and install the latest CompactRIO driver.
  2. Make sure the NI USB driver is correctly associated with Windows.
  3. Force reinstall the CompactRIO driver to force the computer to re-write the installer files again.

If these steps don’t work please help us showing: how the usb adapter shows in the Windows Device Manager, which software is installed in the computer (under the software tab in NI MAX), and if it shows up under Remote Devices in NI MAX or not.

1 Like

I agree that it’s a driver issue. The NI driver that maps the usb to the network is getting pre-empted by an existing driver. In our case, we had loaded a sdk for arduino or some other similar device and it was loaded and ‘recognizing’ the usb before the NI driver. We didn’t have any success removing it and we re-installed the laptop.

If you find the errant driver and can remove it, the NI driver should work.

We ended up updating the FRC Suite and tethering via ethernet instead for the sake of a working driver station laptop for FMA Championship. Will look into this issue in the off-season given the solutions provided.
Thank you!!