RoboRio not doing anything

(Disclaimer: I know nothing about programming language etc. We also tried Discord, but the only response was “Ummm”) Right now, our RoboRio is shot. We used it last season without an issue, but a few days ago it stopped working entirely. The closest we can link it to is someone tried to reformat it when the battery died, but that may not be the issue. Has anybody had this happen to them and do they know what went wrong and how to fix it.

Call NI weekdays during build season –
Monday-Friday, 1:00pm - 7:00pm Central US Time

They will walk you through some hardware testing and send you a way to recover from a corrupted format.

I’m guessing that means we did something pretty bad to it.

When you say “stopped working entirely” do you mean it doesn’t power up at all? If that is the case it may be that you blew the small, yellow, 10 amp breaker in your power distribution panel.

We’re going to look, a few lights turn on but I don’t remember which ones.

This is the document you want to follow. It has all of the troubleshooting steps in the order you should try them, with calling NI being the last step. We actually just ran into the same thing - someone powered down the robot while we were flashing the firmware. None of the first four troubleshooting steps worked, but NI provided a recovery tool after a quick call and it got our roboRIO back up and running.


If your issue is that your Drivers Station doesn’t connect - make sure you have your team number entered.

If you haven’t already tried connecting to it with a USB cable, you should also try that. It bypasses a number of potential network issues that could prevent a connection. Make sure you use a computer that has the Drivers Station installed on it.

If this is what happened, then it’s very likely that this is your problem. If this is your problem, the best and possibly only way to fix it is to do as Mark_McLeod suggests:

The support line is open specifically for FRC and they’re very good at walking you through troubleshooting and fixing the problem. If your roboRIO’s firmware is corrupt (which is likely if it lost power while being reformatted) they can provide you with additional recovery software you will need to restore your roboRIO to working order.

I know this because I once bricked a roboRIO by disconnecting power while formatting it. I wasted at least an hour trying to fix it on my own before I called NI. They helped me fix it very quickly, and I could not have done it without their help. Lesson learned: just call NI!

And while they were not able to help me on the phone, they were happy to RMA a RoboRIO from 2015 last night, so they are helpful and accommodating. The roborio, might be over priced for what it does, but NI does provide excellent support when you need them.

Thanks. We didn’t have to call NI. In fact, we just came back and it started working again.