roboRIO Not Working

Hi, we have a problem with roborio ı hope you can help us. The roborio, which we ran the previous day, was working with a different led combination than we expected when we tried to run it today. We tried to fix it with the reset button but it didn’t work. We tried to connect with usb and network, but the computer does not see the roborio.

roborio - YouTube

1 Like

Looks like it’s power cycling over and over?

How are you powering the roboRIO? and is the power a nice constant 12v?

We are constantly giving 12V over PDP.

My first suggestion would be to check that the fuse in the PDP is seated properly. They have a tendency to come loose, which could cause the voltage to drop below blackout voltage when the roborio draws startup current.

If that doesn’t work, try disconnecting the roborio from the PDP and connecting it to a 12V power supply. If it works there, the problem is somewhere in your power wiring. If not, then it’s something with the roborio itself.

We tried running it with an external 12v but it was something. :frowning:

You can try taking the case off the roborio and blow/vacuum it out. It’s possible that some piece of metal fell inside and is shorting something.

If that doesn’t help, your best bet is probably contacting NI technical support. ni.com/frc

1 Like

I see from your picture that you have something connected to the MXP port. Please remove this expansion card, and clean out the mxp port. Also disconnect anything else you have connected to the RIO, and make sure all the pins are clean. Then power it up again with nothing plugged in.

NavX is installed on the MXP port. Nothing changed when I took it out and cleaned it and tried it.

Today, when I tried to open roboRIO again, it worked normally, but after 10-15 minutes the problem persisted.

A couple
A couple things:

  1. CAN bus requires the use of twisted pair, but untwisting them, your impedance will be significantly different (the only saving grace is that’s a very short cable). So I would fixed that first. Unless you have a CAN bus protocol checker that you can confirm it is passing your CAN traffic properly.

  2. Have you make sure to use a fresh/new battery? Do you have a battery checker to make sure you have a good enough battery (then again an almost dead battery should be able to provide you with enough juice to get the RoboRIO up and running assuming you’re not loading down the battery (seems clear on your PDP pix). [and make sure that you do have the terminating CAN resister settings on properly on the PDP assuming it is the last device on your CAN train].

  3. Disconnected everything but the RoboRIO and PDP and to the Battery. Just because it was working before doesn’t mean anything when you are trying to troubleshoot to find out what’s causing your previously working setup to not work now.

We had an issue similar with one, and it did wind up being a microscopic metal chip in the base of the RIO. If you have a soft-bristled toothbrush, very gently scrub the bottom of the board where the coating is. Even if you can’t see something, it doesn’t take much for a chip to work its way into that coating and cause problems. You can also gently brush the top of the board as well. It doesn’t take much to make them power cycle like that.

ETA: You said it worked normally for 10-15 minutes. Was this AFTER you put the case back on? The foam backing may have taken that long to press a stubborn chip back into whatever it was hitting…

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.