RoboRIO requires imaging prior to each deploy

We have been having issues deploying code to our roboRIO. Ever time we try to deploy code as start up, we get an issue saying the target cannot be found. However, when we reformat the roboRIO prior to the deploy it works correctly. It takes about 7 minutes each time we reformat the RIO and is causing quite a hassle to do this each time. If anyone could help us understand why this is occurring, that would be fantastic :slight_smile:

We are using lab view.

Is that true even with a newly created default LabVIEW project. That test would at least rule out anything in your robot logic, or narrow it down to something with your robot app.

Do you see the same issue if you just press “Run” from Robot Main.vi?

Neither of those deploy correctly. We still get the same error that the target can not be found.

I don’t know whether this contributes to the reason it isn’t working, but every time we create a new roboRIO project in Labview, it does not build correctly unless we delete the visual processing VI. It appears to have missing and broken VIs dealing with the camerea

It’s unrelated to your target problem.
That’s probably due to the Vision license not being activated properly.
See if this post helps with that problem.

For the deploy problem could it be related to this issue?
Are the symptoms similar?
Waiting for Target to Respond - Recovering from bad loops

I don’t know about the Labview deploy (we use C++), but it sounds like the computer running cannot resolve the ip address for the roborio. Some ideas:

  • have you tried usb and Ethernet?
  • have you waited awhile so that the mDNS responses might work?
  • did you try a different computer? The driver station image comes with Labview.
  • can you ping the roborio? Can you log into its console with ssh or ftp?
  • try looking in the router setup and get the ip address of the robo-rio. As a hack, you could try putting that in the hosts file on your pc for roborio-team.local. Note this is a total hack and not recommended to leave in. Back out the change after trying it.

Thank you for all of the suggestions! :slight_smile: It turns out it was actually a very simple problem. We were trying to deploy our code via Ethernet cable through the D-LINK, when we should of been using an USB A to USB B cable to deploy code directly to the roboRIO! This is why it appeared that the roboRIO had to be re-imaged each time, when it reality all we had to do was connect the cord. Again, thank you for the all the help!

You should be able to deploy your code through ethernet and the D-Link; it looks like you have some other problem.

What is the target address (in parentheses) on the Real-Time Target line in your LabVIEW project?

We are having the same problem. I temp fixed it for the “run” option by disabling startup rt and fpga in Web dash. I saw a more advanced error message saying a component encountered an unexpected error and had to restart. I heard something about using the “clean” option before deploying but I’m not sure if that applies to LabVIEW?.