RoboRIO RIOLog in Eclipse Broken! Help!

Hi everyone! I am the new programmer for my team this year, and I just set up Eclipse and all the FRC plugins. I have successfully programmed our roboRIO practice bot, as well as run it. In the past few days, rioLog on Eclipse was working and would give me output for statements in my code where I had “System.out.println” statements. However, just today and yesterday, I have been unable to get any output from the rioLog on Eclipse to help get values from the motors, joystick, etc. Would anyone happen to know why the rioLog seems to have broke down and how I can reset it on Eclipse to work again? Thanks!

Are you using the latest update for eclipse from WPI? That seemed to fix our problems with RIOlog.

Yes. I’m using all of the 2015 FRC Update Driver Station software too. The thing is, everything was working fine just a few days ago when I wrote the code - outputs were recorded perfectly in the rioLog. Yet now when I try to get output from the print statements in my code in rioLog nothing happens. IDK what happened.

Actually Darkseer, scrap that. I did not see there was a new update to Eclipse from WPI. I will update and post if the rioLog issue is fixed :slight_smile:

I just updated Eclipse with the recent update from WPI. Still no response from the rioLog. :frowning: Should I just reinstall the 2015 Update Software and reinstall Eclipse and see if that fixes the problem?

Couple of things you could check first: Make sure your firewall is off (we had that issue as well), and check out your subnet mask. It should be . If it is not then go in and manually change it to that. If that doesn’t help then I’d have to (unfortunately) recommend that you do uninstall and reinstall and see if that works. I’d suggest you post before doing this though.

EDIT: Also, not to be patronising, but check your settings for RIOlog and make sure you are accepting packets and such.

We’ve noticed sometimes if you disconnect then reconnect to the wireless network, the RIOLog magically comes to life.

I.e. after we send code and expect output on the log and get nothing, we’ll disconnect from the 610 wireless network, then reconnect. When the connection comes back, we see our output start showing up.

Hi. So here’s what I have done so far. I reinstalled the Driver Station and other utilities. Reinstalled the WPI Plugin in Eclipse. Set my IP Address on my adapter to Set subnet to Turned Windows Firewall off. Disconnected after uploading code and connected again as Mr. Lim suggested. Still no output coming from rioLOG. :frowning:

Did you recently reimage your roborio? If so did you have the log out on? Also, did you check the settings for RIOlog?

I re-imaged it yesterday to make sure I had all the connection and Bridge Configuration set up correctly. Was there something I did not check in the Imaging Utility to let the RioLog work?

Here’s the issue I’m having, the RioLog option isn’t available for me in show view under general. (running on a mac)

  • I updated eclipse
  • I updated to Java 8
  • I have automatic updates for plugins enabled
  • I restarted eclipse

I’m lost and don’t know what else to do. Any help is appreciated.

Arbalest007 - There should be something in the imaging tool along the lines of console out or log out. Check to make sure you have that checked. Also make sure that in RIOlog all the settings are set to accepting feedback, and not pause or anything like that.

Schnabel - Did you install the FRC toolchain? That’s the only thing I can think of that would be the problem. If you have, just go through the steps for installing again and make sure you follow them line by line. Its a pain, but two days ago I had a problem simply from installing them in the wrong order.

Did you deinstall previous versions of Java or just install Java 8? It may be that eclipse is still using Java 7. The riolog is only available if Eclipse’s runtime environment is Java 8.

If you are connecting wirelessly to the roboRIO, I believe you should be set for DHCP (meaning you should have selected “Obtain IP address automatically”) instead of setting a specific IP address based on your team number as we had to do in the past. I feel like the communications instructions are not very definitive because they don’t give you a specific line-by-line list of what to set, but this works for us.

I believe I am good here. I did follow the instructions when I installed originally and am able to deploy code.

I did not uninstall Java 7, but looking at my runtime configuration Java 7 isn’t an option available any more, I’ll look into this further (thanks for the tip).
Edit: Just forced an uninstall of Java, reinstalled and still no luck.

Network adapter is set to DHCP, mDNS is resolving correctly. I would look into this further if I couldn’t connect, but I can’t get the option to show up in eclipse to add to my view.

Thanks again all!

Hi everyone, sorry for the late reply! I did recently re-image the roboRIO. I was unaware of this option that I probably forgot to check. I will re-image and make sure I have it checked tmmr when the team meets again and will post results :slight_smile: Thanks for helping me diagnose this problem everyone!