RoboRio updated, code not deploying

We updated our RoboRio to version 14, and now code will not deploy. We have power cycled it, loaded the latest WPIlib, updated VScode, and tried to deploy with driver station up and without. We also have been able to access the RoboRio web dashboard, even though VScode says “RoboRio not discovered”
Here’s a picture of what it looks like every one of the 200 times we’ve tried to deploy:

We have also restarted the computer and all programs.

What version of the WPILib plugin are you using? I believe you need 2019.4.1 to be able to deploy with firmware v14 on the Rio.

1 Like

Second ^

How can I tell what wpilib we are at? I think we updated it along with the Rio.

In the, the one of the first couple of lines should contain the version. It should read 2019.4.1. I haven’t experienced this before, but did you rename the Rio when you reimaged?

Ok, so the wpilib is the wrong version, but we have the update file. When we try to run it tells us that the “destination file could not be created”

Have you followed these steps? Also, make sure you download the correct version from Github.

We have to run into that issue before, restart your computer and only click the file once wait a few and it will start installing.

are we supposed to download vs code as well?

You don’t have to. You just need the bottom 3 check boxes.

and this is what it does:

Close all other programs. Also, if you could click details that may help troubleshooting.

Also if someone not at comp today could take over, that would be great. I’m going to have my own work to do, so I may not be able to reply quickly.

Now we updated wpilib, and it shows 2019.4.1, but it gives the exact same error message

Never mind, it worked, just needed driver station open, thanks for all your help.


Ok good stuff

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.