Roborio2 SD card imaging , error to set team number

We are getting this error when setting the team number:

We have done this before during the 2024 season two different times.

It looks like it is working right before we get the error:
set team number

What are we doing wrong. We tried on 3 different laptop and 2 different SD cards (which we have used before with Rio2). We even got the latest Balena Etcher.
selected the patch 2 image:


selected the SD card:

options:
balena etcher - version

We are using USB-B cable, have disable wifi on the laptop / been connected to internet with the laptop, radio connected on rio2 or not.

We put the SD card we used for competition back in and it works fine. Can still deploy code and run the robot.

On Tuesday, we will try more things. We have ordered 2 more SD cards (sandisk industrial 8GB) and will try on another Rio2 we have.

This is very odd, for such a simple process to be consistently failing.

1 Like

So this is two different processes. You image the SD card with Balena Etcher. This is clearly working since you see the correct version in the RoboRio Imaging Tool (assuming this is after you put the newly imaged SD card back in the Rio). Then you try setting the team number via the imaging tool and it fails.

Can you try using the RoboRio Team Number Setter tool instead? It should be in a “2024 WPILib Tools” folder on your desktop if you have WPILib installed

Yes, we will try the RoboRio Team Number Setter tool. Thanks for the suggestion.

When I saw this issue with another team this year, the WPILib RoboRIO Team Number Setter wouldn’t work. I think it’s due to trying to use the string that appears after the roboRIO name (in this case, 0-03249427) for the IP, or something related to this.

I think the solution to this is to try the NI RoboRIO Imaging tool to set the team number again, but either reinstall it or use another PC with it installed. The NI tool may be failing due to the USB driver it uses to talk to the roboRIO not installing properly.

Thanks for the hints.
We tried imagining with Balena Etcher from 3 laptops and then Rio Image Tool to set team number. Same error from all 3 laptops we tried.
We do have one laptop that is newly installed with game tools patch 2. We will try from that one Tuesday.

I’ve seen this error before- the configuration was successful, but it failed to restart the device (as hinted in the error message). When this happens you should just be able to restart using the reset button and the roborio will come up like normal with the new team number applied.

Like mentioned above you can also use the wpilib team number setter- I’ve not seen it fail even when freshly imaged.

Nice. Thanks for the hint. We will try the Team Number Setter first and if that does not work, will try the reset button.

Using the Team Number Setter did the trick. Go figure.
I used USB cable and clicked the Set Team to 68.
It was so quick, I wondered if it actually did it.


I was able to deploy and run robot code after wards.