Robot Builder?


#1

My dad was looking through somewhere and found a little about Robot builder. i was wondering where to download it and the cons to using it. I am using it for Java.


#2

The RobotBuilder come with the 2013 Update- the jar file is located at the sunspotfrcsdk/tools directory- usually something like /Users/<username>/sunspotfrcsdk

Anyways the cons I can think of right now are

  1. Takes away some of the fun parts of programming
  2. From my short usage it doesn’t seem to be perfect(for exampe once the generated code didn’t compil becasue it forgot to include a file) so I’d recommend to still go over the code that it generated.
    (in my opinion the pro’s outway these minor con’s)

#3

There’s a decent amount of documentation on screenstepslive. http://wpilib.screenstepslive.com/s/3120


#4

THANK YOU GUYS so much. :smiley:


#5

I tried it out a bit but decided I’d prefer to do it by hand. I did, however, use their idea of centralizing all of the electrical parts of the robots into static instances in RobotMap. Not necessary if you don’t plan to use livewindow, but if you do it makes things much easier.


#6

i encountered a problem. it wont let me execute the file. is it becouse i have windows 8 or i just dont have something downloaded?


#7

Did it give you an error message? I’m also running windows 8 and haven’t had any issues.


#8

no didnt give me a message, it asks me to choose what to run with it and i just chose java(jdk)


#9

I’ve been following along with the videos on youtube (http://www.youtube.com/user/BradAMiller) and for the most part I’ve had few problems. Unfortunately, we use C++ and the examples during the coding portion aren’t 100% compatible, but they are very close. C++ requires adding include files for commands that are used in a class and accessing methods a little differently (everything is a pointer, so “->” is used instead of “.”).

We have used the iterative template in the past and command programming is new to us. Following the videos, however, I feel the concept is relatively easy to grasp and CERTAINLY much easier to implement in the long run as code reuse can be very high since one can call any command at any time.

Where this really shines however, is in test mode on the driver station (at which point you can manually control and tune subsystems) and manually calling commands from Smartdashboard while the robot is running. This allows one to check out each command before using commands in a sequence and even determine the best command order (or which commands can be run in parallel or need to be run sequentially).

Another great benefit to using this is the ease with which we should be able to get new programmers up and running. Because the basic structure is created by Robot Builder kids can worry more about the logic of programming and somewhat less about the complex structure of C++/Java.

For the last couple years I’ve been somewhat annoyed with all the cool tools the LabView guys get to play with. Its about time we had some of our own. Brad Miller and his guys have really outdone themselves this time.

  • Bryce

#10

In some Java installations on Windows it doesn’t set up the .jar extension to run automatically from Windows Explorer. Jar files are Java archives and have all the classes in the program and a manifest file to tell which class to run.

To run RobotBuilder use the java command:

java -jar RobotBuilder.jar

Actually there will be a version number on RobotBuilder, so choose the actual file name from your installation.

Brad


#11

Has anyone else had the problem of it running once, then not so much?

We ar eon Windows 7 and Robot Builder ran the first time I tried it, then every time I try to run it since, it just gives me the little project create/load window and after that it just hangs with a Java button on the task bar. I tried a reboot, running command line and more. No joy.


#12

It sounds like the window may be offscreen. Try hovering over the Java icon in the taskbar, then the little window when it appears above, right click and select Maximize. If this works you can then click on the title-bar of the window and drag down to get a normal size window on screen.


#13

BINGO! Thanks so much. No I don’t have to run it on my mac :ahh: :ahh:


#14

I’m no team 2130 and we have a problems with robot builder. On one of our computers that is for programming robot builder wont even open or do anything. Our “Lead Programmer” says its a problem with java but we don’t know. And I haven’t been able to find anything on our problem. So if you have had the same please comment and maybe we can figure it out. thx


#15

I’m a big fan of the RobotBuilder, and encourage our programmers to use it, at least at first. With novice programmers, I can walk them through creating a driving robot in fifteen minutes.

If you haven’t seen it, I recommend watching Brad Miller’s videos. RobotBuilder is a wizard that puts together a command-based robot. Without RobotBuilder, you would need to understand the command-based software architecture first, and then do the low level coding of commands and subsystems later. By starting with RobotBuilder, would can construct the architecture in a visual manner, and then start your work on the low level components.

It does some of the code, but there will still be tons of work left to do. It will not make coding easy, but it will give you a solid foundation on which to work. Also, you will absolutely need to understand the resulting code; you will have serious problems if you don’t eventually understand how the command pattern works.

There are lots of other pros and cons. On the plus side, it generates a wiring diagram that is terrific for communicating with the electrical team. On the minus side, it generates some ugly code that might not work exactly how some coders want. It sometimes forgets to import all necessary classes. Also, keeping the code and the robot file in sync can be problematic.


#16

Try running it from the command line, java -jar <robotbuilder jar file>. See what it reports.


#17

So…thread necromanceries here but when I try executing RobotBuilder from the command prompt we get “Error: Unable to access jarfile RobotBuilder.jar”


#18

Are you in the same directory as RobotBuilder.jar?


#19

Whelp, that would’ve undoubtedly helped…guess I shouldn’t do this stuff when I’m half asleep. XD

But still…nothing opening, do you want me to post what the cmd prompt came up with?


#20

Yes