Robot Builder?


#21

C:\Users\jones\wpilib ools>java -jar RobotBuilder.jar
Extension components: ]
Adding extensions for section: Hidden
Adding extensions for section: Subsystems
Adding extensions for section: Controllers
Adding extensions for section: Sensors
Adding extensions for section: Actuators
Adding extensions for section: Pneumatics
Adding extensions for section: OI
Adding extensions for section: Commands
Extension components: ]
Extension components: ]
Extension components: ]
Exception in thread “AWT-EventQueue-0” while scanning for the next token
found character ’ ’ that cannot start any token
in “<reader>”, line 3, column 1:
<static-widget class="edu.wpi.f …
^

    at org.yaml.snakeyaml.scanner.ScannerImpl.fetchMoreTokens(ScannerImpl.ja

va:413)
at org.yaml.snakeyaml.scanner.ScannerImpl.peekToken(ScannerImpl.java:247
)
at org.yaml.snakeyaml.parser.ParserImpl$ParseDocumentEnd.produce(ParserI
mpl.java:264)
at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:160)
at org.yaml.snakeyaml.parser.ParserImpl.getEvent(ParserImpl.java:170)
at org.yaml.snakeyaml.composer.Composer.composeDocument(Composer.java:12
4)
at org.yaml.snakeyaml.composer.Composer.getNode(Composer.java:84)
at org.yaml.snakeyaml.constructor.BaseConstructor.getData(BaseConstructo
r.java:104)
at org.yaml.snakeyaml.Yaml$1.next(Yaml.java:501)
at robotbuilder.robottree.RobotTree.load(RobotTree.java:387)
at robotbuilder.robottree.RobotTree.load(RobotTree.java:361)
at robotbuilder.MainFrame.openDefaultFile(MainFrame.java:141)
at robotbuilder.RobotBuilder.lambda$main$85(RobotBuilder.java:44)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
at java.awt.EventQueue.access$500(Unknown Source)
at java.awt.EventQueue$3.run(Unknown Source)
at java.awt.EventQueue$3.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionP
rivilege(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)


#22

I have a theory on what’s going wrong for you. When RobotBuilder starts up, it tries to load the robot configuration file it was working on previously. The name of the file it was most recently working on is stashed using Java’s Preferences utility. I think that on your system it is mixed up, and is reading a file that is isn’t a valid RobotBuilder YAML file.

If we clean out RobotBuilder’s preferences, then it should revert to opening up a blank robot configuration.

Unfortunately, I don’t know that there is anything in the RobotBuilder code to self-correct on this subject. Java preferences are stored in different locations for each different operating system. Macs keep them in PLIST files in the user Library. I think Windows stashes them in the registry. Linux has its own set of files.

The simplest solution I can think of is to run a short Java program that cleans out the RobotBuilder preferences. Try compiling and executing the following. It won’t do any harm to your system:


import java.util.prefs.Preferences;

public class PreferencesCleaner {

	public static void main(String] args) throws Exception {
		Preferences prefs = Preferences.userRoot().node("robotbuilder.MainFrame");
		prefs.clear();
	}

}


#23

The old or corrupted preferences or previous save file seems like it might be your problem. Have you gotten past the issue you were having?


#24

This fixed it! Thanks a million!


#25

Wow… just watched the Robo Builder overview videos from Brad Miller and i am excited…

Can this be use for both FTC and FRC?

We are a rookie team, we depended on one programmer last season and he did good with labview with no experience, unfortunately he is leaving for college and we are starting our programming team from scratch.

Many teams recommended going to JAVA as it would be a much easier programming language to ;earn for beginners and there is tons of ways for the students to learn it… I am still not totally sold as Labview seem to have some great material online too…

And then i found this thread… I really like what i seen in the video… just trying to wrap my head around where to start and how much of a learning curve is it going to be…

Our programmers will most likely work on both the FTC and FRC robot next season and beyond !

Any input would be appreciated…


#26

So, me and my team were hoping to start using this to kick things off in programming, but we are unsure of how to actually install this. How would we do that?


#27

RobotBuilder is installed as part of the WPILib installer. See 2019 Kickoff Release of WPILib

Once you’ve run the installer, you can run RobotBuilder either within vscode (using the WPILib menu and running “Start Tool”, or you can browse to C:\Users\Public\frc2019\tools, and run RobotBuilder.vbs to run it directly.