Robot characterization tool

OK we’ve gotten the characterization code to generate and deploy, but when we run it, the robot does nothing. There’s no obvious indication that we did something wrong, but it just sits there. Does anyone have any ideas about how to get this corrected?

You don’t provide much detail, but a few basic things can go wrong to cause this.

  • Are you “Connected” to the robot in the Logging tool?
  • Did you run a test?
  • Did you dismiss the pop-up dialog box in the Logger?
  • Did you then enable Autonomous mode?

The quasistatic tests can take a couple of seconds before the robot starts moving.

1 Like

I didn’t provide a whole lot of information. My apologies. We’ve followed each step in the instructions shown in the WPI docs. The GUI showed that we were connected and that the forward Quasistatic test was running. The robot sat idle for 30+ seconds, so perhaps we should have been more patient. I’m looking through CD for other challenges like this, so hopefully there’s a hint of a solution somewhere and I haven’t uncovered it yet.

Do you have any suggestions about what additional information would be helpful in getting sharing here?

Thanks for your reply.

I am new to this myself, but I have run the characterization tool successfully - and not - several times. I have found it to be a little bit finicky.

The steps I mentioned, above, are the things I’ve run into that cause the tool to fail. I would emphasize that you have to dismiss the pop-up dialog in the Data Logger before you enable Autonomous mode on your robot, or it will not run the tests.

1 Like

The other thing you could do is look for any errors in the console window from which you launched the characterization tool. Is there anything odd going on there?

1 Like

Another thing to look at is in Network Tables there should be a some variables there that the characterization program uses to run the test. Can you see if those are changing?

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.