Robot code deploy is slow

Today, I needed to deploy the robot code because of some problems with motor controllers. For some reason, when I tried to compile it, the connection in USB type-c cable or wireless via radio was taking a time of 8/10 minutes or more. In this case, I was using Windows.
So, I switch to Linux and tried to deploy, to test how much the deploy delays to send the code. Now, the code was taking a time of 2/3 minutes.
Why in the first case the robot code deploy is slow? I updated the WPILib packages in RoboRIO and computer, but it didn’t work. If you use a another robot code, the delay doesn’t change and doesn’t show errors in the terminal or Driver Station.

  1. Firewall enabled?
    • Even with ports opened, it’s still likely routing traffic through it which could potentially affect speed, albeit likely not that much)
  2. Antivirus software enabled?
    • This may have network scanning functionality and could certainly impact speed
  3. Multiple NICs enabled?
    • The deployment tooling will attempt to locate the roborio via mdns, dns, “known” team number IP, known USB IP, etc… multiple NICs can add significant delays to this process
  4. nimdnsresponder service running?
    • Without it (or similar service to handle mdns traffic), the mdns step (from above) may have to time-out before continuing to the next attempt.
  5. Windows simply isn’t very efficient with certain things
    • Would not explain the delay you’re seeing on its own, but may be a contributing factor

Having said that, this is all just an educated guess. We would need more info to help diagnose it. The deployment logs would be a good start.

Also, I see you’re posting in the python category. Is that accurate? If so, are you having issues deploying python code, or the base project (via vscode with wpilib plugin)? I admittedly don’t have much experience with python, so my ability to help from that side will be limited.

2 Likes

What version of pyfrc do you have installed?

Please post the output from your terminal when you run the slow deploy.

1 Like

I do not have much to add other than to say that with PyFRC, this is not normal. Our deploys are almost instantaneous.

1 Like

That is definitely slower than the deploys we are used to.

The have been a few instances when the deploys were slower. One was when the computer itself was running slowly, and that required a restart (not an optimal solution). Another circumstance is that the connection itself is slow, and that has happened when the robot is further away.

1 Like

yeah, our team uses robotpy for programming. But this doubt isn’t about a problem in code, because the terminal doesn’t return a warning or error in a specific line. I was in doubt whether to put in python topic or not.

For us, it also worked instantly for a while, now that it is slow. :frowning:

image


I saw this topic and looks interesting, because this option is deactivated. I don’t remember why I turned off, and probably the NI services should affect the robot’s connection.
I’m not with the robot now, but I’ll try later. :slight_smile:

image

1 Like

Today, I activated all NI services and it worked. Thanks @Fletch1373 :slight_smile:

2 Likes