Robot Controller Broken?

We just got our kit of parts well… that’s rather obvious but, we can’t seem to get it working. The main issue at hand is that while we can get the robot controller to turn on, and we can upload and accept code, it doesn’t seem to accept the radio.

Here’s what we did:

  1. Took the robot controller out of an old robot and plugged in the new robot control with just the radio port, 12 volt power supply, and the backup battery. The radio had power and the standby light came on, and every so often it blinked to the recieving light once, then jumped back to standby. But the light for the radio on the robot controller stayed on steady red… it didn’t see the radio.

The operator interface lit up (we set the team number), and the radio had a constant blink on the transmit light, and every few seconds it blinked the standby light once before flipping back to the transmit. We tried switching the operator interface between IO and RC (we reset everything every time we changed a setting). Still nothing.

  1. We tried switching the radios (put the “operator interface” radio on the robot controller, and the “robot controller” radio on the operator interface), then both were steady on the standby. Clearly, we had it right the first time.

  2. After switching the radios back, tried switching the serial cable. No effect.

  3. We tried uploading the FRC 2007 code (the default with the new master code from First we tried FRC_Default.hex Then we compiled it ourselves and uploaded that FRC.hex Same problem, and nothing came on the terminal after uploading code or resetting.

  4. Then we tried the stuff from Still nothing.

  5. Tried the default code from last year, then tried the stuff we edited (that was also from last year).

  6. Then we tried using the new radio with last year’s robot. They connected, no problem. Solid signal, and could control it. So we know it can’t be a problem with the radio or the operator interface.

  7. We hooked up the tether using nothing but the 2007 stuff. They connected, and the Terminal got a readout (“2006 Processor initialized… No Camera Data…”). After hooking up the cmera it also properly searched, the Robot Controller seemed to be fine except…

We think that we have a dead radio port. Anyone have any ideas for testing the radio port? Or know what we have to do to return a broken part? Sorry about length, I tried to be as detailed as possible so that you could see we tested it fully.

Try tethering the OI and RC. The team number on the OI and RC must match or they won’t connect, and the RC gets set when you tether it.

If they still won’t connect contact IFI.
Hope this helps.

Hooray! It started working, but it seems like it’s reluctant to retain those settings (after turning off power there seems to be a 50/50 chance that it will properly connect again when turned back on). But yeah, a little aggravating that we were only one step away from getting it working. Thanks for the tip!