Robot Crashes with voltage spike

Well, here it is week 4 and we are still having issues with running our robot…

Every time that we run our 4 wheels (with 4 motors, tank drive) in the required direction to turn in place to the left (left wheels back, right wheels forward) our robot crashes. The motors suddenly hit full speed, and then we can no longer control them. According to the Drivers Station, we are still enabled, and our program continues to print to the modual in wind river. The four jaguars go to their flashing orange light and will not allow control until it is re-enabled from the Driver Station or we reboot the robot. This happens both in Autonomous and Teleop. The speed of the motors does not influence whether or not it crashes. It also will sometimes happen when we move the right joystick forward or when we move the left stick backwithout moving the other, but will always happen if we do both at once. It does not happen when we turn in place to the right, only left. We have measued the output of the Jaguars. When running normally, at full speed they output 11.7-11.85v. When it crashes, it spikes to 12.05 before control is cut.

Here’s what we have tried so far to find the source of the problem:

  • It does this with LabView and C++, so we assume it is a hardware problem.
  • Unplugging the motors from the jaguar motors doesn’t make a difference.
  • It will still crash when all but 1 jaguar has its pwm cable removed (We don’t try all 4 as we then have no way to see if it has crashed or not).
  • We have tried replacing the SideCar to no avail.

Any ideas why we are getting this crash + voltage spike?

What you describe is a classic example of all four CIM motors in stall causing the battery terminal voltage to fall to the point at which the Crio power supply no longer supplies the 24 volts and the Crio resets. You are using the +24 volt output on the Power Distribution board to feed the Crio right? Likewise you are also using the +12 volt output to feed the wireless adapter on the robot?
If I understand your question, you also experience the same problem with no motors connected? You don’t have the Jaguar outputs cross connected do you? Have you checked to see if you have any electrical connections to the chassis? Try checking with a VOM by first removing the battery, then measure between the robot frame and the positive and then the negative lead on the PD. You should measure at least 10000 ohms depending on the humidity and in most cases well in excess of 1 meg ohm. It is possible that somewhere you have two outputs shorted to frame (perhaps through the camera mount) and under just the right conditions, you are shorting the battery.

Accidentally wiring the outputs of two different speed controllers to a motor causes some pretty bizarre behavior. Wiring the other outputs of those speed controllers to another motor can end up shorting the power supply when you try to run the two motors in specific directions. That does sound like a real possibility here. Make absolutely sure that you have the output of each Jaguar going to one and only one motor.

I am part of the team having problems. Just a few more points. After having problems with shorts last year we have tried to keep all bolts and conncetions off of a possible connection. We have replaced some parts of the Crio, tightened wires, and checked connectins with no success. I will review all of our wiring today and connections that you have suggested and post another update but the more ideas the better right now.

Well I have tested what you suggested and none of the ideas were the problem. As always any ideas are welcome and we still don’t have a working bot. Sorry it didn’t help.

Just to be sure, your original poster suggested the problem exists with the motors disconnected also?

yes, the problem exists with the motors disconnected also. We did discover that the wires to the motors out of the power distribution board were not connected correctly, they were crosswired. We rewired them, problem still existed. Then we replaced the power distribution board, but we still get the same result as before.

This is not a failure mode we have seen before but I think one of your Jaguars is shorted. So here is a way to troubleshoot the offending circuit.
Connect everything as you would for a functioning robot. PWM wires, power supply wires and motors.
Remove all but one of the circuit breakers and try driving. If all is ok, then pull the first one out and put in another one. This test will show if one of the circuits is shorting the power supply. Then you will only have to check in one circuit. This should show that one of the four controllers is causing the problem. Check all your wiring in that branch. It is possible for a small strand to short across two terminals and cause this problem, so be sure of all connections. Take them apart and inspect each in a bright light. If you need to call I will be home for about an hour. I will PM you with my home phone.

we will try this, but just looking at the Jaguars, it’s hard to imagine that there is a short in there. We did monitor the voltage from the battery, and when we put it into crash mode, the battery voltage dropped to 10 volts.

We’ve disconnected all the circuit breakers but one, so only one of the Jaguars is working. It does exactly as it’s supposed to if we operate it with the right joystick, forward and back, with no response to left joystick. However, if we simultaneously put the right joystick hard forward and the left joystick hard back, operation stops (the user interface disables). The Jaguar just flashes yellow - standby mode.

With two circuit breakers connected, one right and one left motor connnected. we can put the joysticks in any configuration except the right one forward and the left back. Only this crashes the system.

We are using last year’s CRIO, new Jaguars, which have been tested. We did replace the power distribution board with last years.

So you get the problem even without breakers in place? Is it possible that you have a shorted PWM cable? A slow flashing yellow indicates a loss of PWM. Try removing all four of the PWM cables from the sidecar and see if your condition still exists.

A correction here, the joysticks don’t have to be hard forward and back for the crash to occur. If you move them into position slowly together, it actually happens when they are about 1/4 of the way from center. If you have one all the way forward or back, and ease the other one in the other direction, it crashes when it reaches 1/4 from center. This happens even when you switch the joysticks.

No wires should go directly from the power distribution board to the motors. Wires go from the PD board to the Jaguars’ input and other wires go from the Jaguars’ output to the motors.

If you reversed connected the input power to the Jaguars, they are most likely destroyed. When a power FET is destroyed, it will usually become a short circuit.


What they meant was a wire was crossed between PD board and jaguar. One PD board slot had a positive slot going to one jaguar and its negative going to another, while the negative of a second slot went to the first jaguar and its positive to the second jaguar.

I hope I didn’t word that too oddly.

the jaguars still work though - everything operates normally unless we put the joysticks in the configuration i mentioned before. i don’t think they were reversed wired, what happened is that the positive and ground wires from the PDBoard for a particular Jaguar did not come from adjacent terminals from the PDB, for some strange reason. god knows how it got wired that way.

Have you tried taking the PWM cables out of the sidecar and try the joystick again?
I should have asked, are you tethered when this occurs?

yes, we are tethered. I think we tested it with the PWM cables removed yesterday, but the person who would know that has left - he might reply later. Folks went to dinner, but we can try some things a little later tonight.
We loaded our code on last year’s robot, using the same CRio but different Jaguars, and it works fine. not su
thanks so much for your help!

I am heading out to robot class. I won’t be back on line for a several hours if at all. Hope you find what the problem is.

The Jag has an H-Bridge power output configuration.

Look at the diagram at the top right of this page. S1 and S4 are closed to go forward and S2 and S3 are closed to go backward.

Now imagine that the FET S4 has shorted. When the Jag is at neutral, no problem. When S1 is closed, no problem. But when S3 is closed, you get a condition known as a “shoot through” which is a short circuit…


We’ve been running tethered. Radio is just one more thing that can go wrong :wink:

I have just discovered that our electrical team made a mistake in how they power the Side Car. I believe this is the problem. I’m going to test that theory tomorrow afternoon and get back then.

Thanks for all your help!

we did in fact find the problem

our electrical team hadnt hooked the Side Car to the power distribution board: it was reciving power only from the data cable from the cRIO.

Thanks again for all your help!