Robot Drive Train Characterization NT Timeout

We have been using the WPILib Characterization Tool and have been having an issue When we try to run any of the routines and enable Autonomous Mode the test runs smoothly until we end the test by disabling the robot there is a lag of about 10 seconds then the Characterization program returns an error of Timed out receiving NT and records no data. We have tried everything we could think of including checking if the java program is collecting data, it is, re installing the tool, it didn’t change the error, and several other things and we are lost for what we can do, my best guess is that there is something going wrong with the connection between the java running the robot and the python running the tool possibly in the 2021 version(I ran the characterization tool last year and it worked). Does anyone know how to solve the error or at least know more about the exact cause?

I’m having the same issue for simple-motor characterization, while it also worked fine for me in 2020. Forward and backwards quasistatic appears to work but no data is recorded (encoder values in json are 0) and the dynamic tests just says NT time out upon disabling autonomous.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.