Robot motors don't move and only pneumatics works

so our robot broke down during competition. It just didn’t move.
We assumed it was because our can bus was overloaded - we have 17 devices showing up in Phoneix tuner and we use roborio 1 - so we decreased that through code. Now it’s not constantly hitting 100%, but around 60~70%.

However, it still didn’t start (only pneumatics worked).
The first few times we disabled RT start up through the rio imaging tool and reenabled it, and that seemed to work a couple times but now it does not work.

We were trying to see if it’s a computer problem or a controller problem, and even when we swap it it does not seem to change the results.

We tried running our old bot, and shockingly it showed the same behaviour our new bot was showing, which was not like that before.
our console was being spammed by the “can bus too stale” error messages.

Now we’re trying to re-do all of our can bus connections and add a device one at a time and see if that does anything.
of course, we will have to reimage the rio every single we try to deploy the code.

please help.

1 Like

I would check for any computationally intensive operations you’re doing in Teleop and periodic tasks. Specifically, look for loops that have no delay or are faster than they need to be. You can see the roborio cpu spike to ~90-95 percent when enabled in teleop but when disabled it drops to just over 60.

The CAN bus congestion, CPU usage, and packet loss are all separate issues that stack up to unpredictable undesirable performance

that was our old bot, so we decided to focus on our new one.
we made sure our bot was receiving joystick values. however, in the deployment process, our robot suddenly started working when we literally chagned nothing.
we turned it off and on again and now it’s dead again.

We had a similar issue early on. We are only running Falcons on the robot, all the falcons would not respond but the pneumatics would. We found redeploying code fixed this temporarily but after a few enables/disables it would come back. Which version of WPILib is your team using? I believe early on others had experienced a similar issue and it had been addressed in later releases of WPILib. I don’t recall if we had the can bus errors you are experiencing though

yes, redeploying code sometimes fixes it but sometimes it doesn’t.
Our team uses labVIEW, the most current 2022 version.
Have you ever found a way to permanently fix that issue?

Make sure your CAN network is properly terminated. Most of the time it should go from RoboRIO → motors / pneumatics → PDP

What colors are your motor/motor controller lights when you’re enabled and disabled?


Team 3142 uses LabVIEW and CTRE products (Falcon 500 and Talon FX) for our motor controllers, just like you do. Earlier this season, we experienced what appears to be the exact same situation as you. What finally fixed the issue is reading the documentation below and following the instructions therein:

This was fixed in a previous CTRE release (still post kickoff) and the latest update just came out a few days ago. Updating solved this for teams at Heartland.


updating the CTRE library fixed everything. 5411 loves you very much.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.